找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 13338|回复: 14

[基础] 如何解决游戏掉线问题

[复制链接]
发表于 2016-8-5 20:59:03 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有账号?注册

×
游戏每天掉线,今天发现,好像是路由器问题,


路由器的设置都是默认的:
# aug/05/2016 20:46:47 by routeros 6.36
# software id = YGUS-3VX2
#
/ip firewall nat
add action=masquerade chain=srcnat log-prefix="" out-interface=pppoe-out1 \
    src-address=192.168.0.0/16


故障描述:
游戏里换场景的时候,
game就从另外一个服务器和我通讯,
今天发现,路由器路都视为 input  丢弃了。如图:
route05.png


我想,就是这个原因,所以掉线。
谁知道解决办法,谢谢




routeros
发表于 2016-8-26 23:16:53 | 显示全部楼层
我这里也遇到类似的问题的了
CBD区域,客户报装的是电信100M/8M光纤宽带,我本来还以为是常见的pppoe,结果带宽下地才发现不是,电信下地的设备已经是个NAT有dhcp分配192.168.0.1/24(我还不可管),测速倒是一切正常,但客户就是反应慢,尤其是是新闻发布后台上传图片的时候明显慢(比家庭版更低带宽的电信宽带下还明显慢),我直接vpn到同城市另一个电信客户就立刻改善
routeros
回复 1 0

使用道具 举报

发表于 2016-8-5 21:07:02 | 显示全部楼层
坚定认为还有其他策略导致被drop


照你说的,网吧都别用ros了
routeros
回复

使用道具 举报

 楼主| 发表于 2016-8-5 21:22:30 | 显示全部楼层
就是相信ros,
就买了一个 rb941 ,家里。
设置都是默认的 电脑接rb941的3口,

好像路由器默认启用 fasttrack
单位里 我很少玩游戏,没有发现这个input问题

routeros
回复

使用道具 举报

发表于 2016-8-5 21:26:32 | 显示全部楼层
log已经很明确告诉你去看firewall了啊
routeros
回复

使用道具 举报

发表于 2016-8-5 21:26:54 | 显示全部楼层
雙wan需使用路由標記 ,您有做吧...留言版過去有匯整給您過資料.
routeros
回复

使用道具 举报

 楼主| 发表于 2016-8-5 21:29:02 | 显示全部楼层
cspm333 发表于 2016-8-5 21:26
雙wan需使用路由標記 ,您有做吧...留言版過去有匯整給您過資料.

这个rb941是单独的,
家里用的。

以前请教你的问题,都是公司用的路由器。
routeros
回复

使用道具 举报

发表于 2016-8-5 22:31:12 | 显示全部楼层
贴你的firewall出来
routeros
回复

使用道具 举报

 楼主| 发表于 2016-8-5 23:29:58 | 显示全部楼层
本帖最后由 xuxi3201 于 2016-8-6 11:04 编辑

没有内容 可以贴。
只有一个自定义log规则, 用来看的。
.游戏里换地图(场景)  卡了, 然后就掉线。
很固定,去某个地图,80%掉线。
.
下面截图里,119.167.254.214:3735是游戏服务器过来的数据.


route08.png
routeros
回复

使用道具 举报

发表于 2016-8-6 12:42:28 | 显示全部楼层
看不出个所以然(你的策略),为什么特意accetp imcp和dns?
当然,这和你的问题无关

你的log已经提示这个信息是在firewall输出的了(现在知道是你特意加的策略,但之前你没说啊-_-"),既然有东西输出log,当然就应该往firewall看
至于这个rst...不知道,你ping一下描述的ip估计一下连接质量?(不过作为移动ip,真心觉得好极有限)
routeros
回复

使用道具 举报

发表于 2016-8-6 13:38:44 | 显示全部楼层
本帖最后由 cspm333 于 2016-8-6 13:50 编辑
xuxi3201 發表於 2016-8-5 23:29
沒有內容 可以貼。
只有一個自定義log規則, 用來看的。
.遊戲裡換地圖(場景)  卡了, 然後就掉線。

我覺得您不要想的太複雜,
有可能只是遊戲需設映射port ,映射conns到您的桌機罷了.

假設您的桌機ip為192.168.3.100 ,請匯入:
/ip firewall nat
add action=dst-nat chain=dstnat dst-address=100.64.136.1  to-addresses=192.168.3.100

Ps: Routeros 6.36有新防火牆RAW,權限高於mangle/filter/nat ,
建議您更新使用.
http://gregsowell.com/?p=5286

routeros
回复

使用道具 举报

 楼主| 发表于 2016-8-6 13:50:56 | 显示全部楼层
谢谢 seignior ,  我估计是游戏客户端的问题,  游戏自己变ip的。 路由器nat没有故障。
      
谢谢 cspm333,  我加一条你说的语句,试试看。
routeros
回复

使用道具 举报

发表于 2016-8-6 14:03:25 | 显示全部楼层
我个人觉得,先到你的isp投诉要求公网ip(你这个100.多少的ip是二次nat之后的ip吧?你随便找个确认ip的网址看看),然后暂停除了nat之外的其他策略再试试
routeros
回复

使用道具 举报

发表于 2016-8-24 16:33:42 | 显示全部楼层
电信的内网IP 100.64.X.X
routeros
回复

使用道具 举报

 楼主| 发表于 2016-8-25 16:31:22 | 显示全部楼层
我是家庭移动宽带,

实际使用情况是这样:
这个月(2016.08) 我用了vpn,拨号到"同城市的一个固定ip的移动宽带"  
游戏没有出现过掉线的情况。
routeros
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由 ( 渝ICP备15001194号-1|渝公网安备 50011602500124号 )

GMT+8, 2024-6-24 20:15 , Processed in 0.077992 second(s), 6 queries , Gzip On, Redis On.

Powered by Discuz! X3.5 Licensed

© 2001-2024 Discuz! Team.

快速回复 返回顶部 返回列表