找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 33379|回复: 26

[脚本] 请教大神ROS电信联通多线做PCC

[复制链接]
发表于 2016-12-22 22:37:41 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有账号?注册

×
两组 PCC   联通一组2条100   电信一组  4条20

游戏走电信  网页视频走联通  

如何做   客户获取的DNS 是电信主      联通辅?   能达到好的效果 。。



routeros
发表于 2016-12-23 01:18:57 | 显示全部楼层
最近也在玩不同的ISP组PCC,我用公用DNS,114。万一任意一个ISP出故障也不至于不能上网,类似于热备。尝试过楼主你说的。方法就是标记指定线路,正常的时候没什么,有一条线路出故障就全部网络不正常。首先不清楚你网络的用户量,而且按带宽来说,用哪个做主线路都应该不是问题。问题在于你说的这两个条件涉及的面太广,端口太多。一条一条的做工作量很大,击中率也低。况且整个网络不止你说的这两个条件,还有很多条件要指定。我是放弃了。直接电信主,除电信IP以外的全走其它。这样利用率高,做好限速就可以了,正常的没几个玩游戏还非要一边看在线电影的。自己觉得卡他会关掉其它应用专心玩游戏的。
routeros
回复

使用道具 举报

 楼主| 发表于 2016-12-23 01:30:36 | 显示全部楼层
zh1000000 发表于 2016-12-23 01:18
最近也在玩不同的ISP组PCC,我用公用DNS,114。万一任意一个ISP出故障也不至于不能上网,类似于热备。尝试 ...

你的意思是电信主       联通用路由表 加 80  443 8080  ?

那客户端的DNS  主电信    备用联通?



有脚本参考么?   
routeros
回复

使用道具 举报

发表于 2016-12-23 02:53:40 | 显示全部楼层
本帖最后由 cspm333 于 2016-12-23 12:18 编辑

在/system scheduler 新增網頁視頻script ,interval設00:00:20
轉換過的地址將存到/ip firewall address-list 的video菜單裡

:foreach i in={"2016.cctv.com";"3g.music.qq.com";"a.play.api.3g.youku.com";"a10.video.qq.com"; \
"ac.qq.com";"acc.music.qq.com";"access.tv.sohu.com";"aid.video.qq.com";"aidbak.video.qq.com"; \
"api.3g.cp31.ott.cibntv.net";"api.3g.tudou.com";"api.3g.youku.com";"api.appsdk.soku.com"; \
"api.hubo.ott.sohu.com";"api.launch.hd.sohu.com";"api.le.com";"api.letv.com";"api.live.letv.com"; \
"api.mob.app.letv.com";"api.mobile.youku.com";"api.my.le.com";"api.ott.tv.cp45.ott.cibntv.net"; \
"api.platform.letv.com";"api.tv.sohu.com";"api.www.letv.com";"api.youku.com";"apistat.wasu.cn"; \
"app.bilibili.com";"bangumi.bilibili.com";"bkvv.play.aiseet.atianqi.com";"bkvv.video.qq.com"; \
"bobo.video.qq.com";"bplay.g3proxy.lecloud.com";"c.y.qq.com";"cache.m.iqiyi.com"; \
"cache.video.qiyi.com";"cache.vip.qiyi.com";"cdn.api.my.letv.com";"chrome.2345.com"; \
"cibn.api.3g.cp31.ott.cibntv.net";"client.api.ttpod.com";"cloud.gslb.letv.com";"ctc.qzs.qq.com"; \
"data.video.qiyi.com";"dispatcher.video.sina.com.cn";"douban.fm";"dyn.ugc.pps.tv"; \
"dynamic.app.m.letv.com";"dynamic.live.app.m.letv.com";"dynamic.meizi.app.m.letv.com"; \
"dynamic.recommend.app.m.letv.com";"dynamic.search.app.m.letv.com";"epg.androidtv.cp61.ott.cibntv.net"; \
"epg.api.pptv.com";"flvs.video.qq.com";"g3.letv.cn";"g3.letv.com";"geo.js.kankan.com"; \
"geo.js.kankan.xunlei.com";"gslb.live.video123456.com";"h5vv.video.qq.com";"hot.vrs.cp45.ott.cibntv.net"; \
"hot.vrs.letv.com";"hot.vrs.sohu.com";"hot2.vrs.sohu.com";"httpbin.org";"i-play.mobile.youku.com"; \
"i.play.api.3g.youku.com";"i.y.qq.com";"ice.video.qq.com";"iface.iqiyi.com";"iface2.iqiyi.com"; \
"info.zb.qq.com";"info.zb.video.qq.com";"inner.kandian.com";"int.dpool.sina.com.cn";"interface.bilibili.com"; \
"interface.url.hifuntv.com";"internal.check.duokanbox.com";"ip.apps.cntv.cn";"ip.kankan.com"; \
"ip.kankan.xunlei.com";"ip.kugou.com";"ip2.kugou.com";"iplocation.geo.qiyi.com";"ipservice.163.com"; \
"leju.down.letv.com";"list.youku.com";"listso.m.areainfo.ppstream.com";"live.coop.gslb.letv.com"; \
"live.g3proxy.lecloud.com";"live.gslb.letv.com";"live.pptv.com";"live.tv.sohu.com";"lixian.xunlei.com"; \
"m.letv.com";"mobi.kuwo.cn";"mobile.api.hunantv.com";"mobilefeedback.kugou.com";"module.youku.com"; \
"mqqplayer.3g.qq.com";"music.163.com";"music.baidu.com";"music.sina.com.cn";"my.tv.sohu.com"; \
"openapi.youku.com";"p.api.lesports.com";"pad.api.hunantv.com";"pad.tv.sohu.com";"pay.tudou.com"; \
"pay.video.qq.com";"pay.youku.com";"paybak.video.qq.com";"pl.youku.com";"pl2.cp31.ott.cibntv.net"; \
"pl2.youku.com";"play-ali.youku.com";"play-dxk.youku.com";"play.api.3g.tudou.com";"play.api.3g.youku.com"; \
"play.api.cp61.ott.cibntv.net";"play.api.pptv.com";"play.baidu.com";"play.g3proxy.lecloud.com"; \
"play.youku.com";"proxy.music.qq.com";"proxymc.qq.com";"qc.hd.cp45.ott.cibntv.net";"qzs.qq.com"; \
"s.plcloud.music.qq.com";"sasdk.3g.qq.com";"sdk.m.youku.com";"serviceinfo.sdk.duomi.com"; \
"sns.video.qq.com";"so.open.163.com";"sohu.vodnew.lxdns.com";"spark.api.xiami.com";"st.live.letv.com"; \
"stat.3g.music.qq.com";"static.api.sports.letv.com";"static.itv.letv.com";"statis.api.3g.cp31.ott.cibntv.net"; \
"store.tv.api.3g.youku.com";"store.xl.api.3g.youku.com";"tingapi.ting.baidu.com";"tjsa.video.qq.com"; \
"tms.is.ysten.com";"tools.aplusapi.pptv.com";"tt.video.qq.com";"tv.aiseet.atianqi.com"; \
"tv.api.3g.cp31.ott.cibntv.net";"tv.api.3g.tudou.com";"tv.api.3g.youku.com";"tv.weibo.com"; \
"u.api.sports.letv.com";"user-mobile.youku.com";"user.cibn.api.3g.cp31.ott.cibntv.net"; \
"user.tv.api.3g.youku.com";"v.api.hunantv.com";"v.iask.com";"v.pps.tv";"v.pptv.com";"v.youku.com"; \
"v2.tudou.com";"v5.pc.duomi.com";"vbj.video.qq.com";"vcq.video.qq.com";"vdn.apps.cntv.cn"; \
"vdn.live.cntv.cn";"video.sina.com.cn";"vip.sports.cntv.cn";"vsh.video.qq.com";"vv.play.aiseet.atianqi.com"; \
"vv.play.cp81.ott.cibntv.net";"vv.video.qq.com";"vxml.56.com";"way.pptv.com";"web-play.pplive.cn"; \
"web-play.pptv.com";"wtv.v.iask.com";"www.iqiyi.com";"www.kugou.com";"www.kuwo.cn"; \
"www.soku.com";"www.tudou.com";"www.xiami.com";"www.yinyuetai.com";"www.youku.com"; \
"xl.api.3g.youku.com";"xyy.video.qq.com";"zb.s.qq.com"} \
do={do {/ip firewall address-list add list=video address=[:resolve $i] timeout=7d} on-error={}}

----------------------------------------------------------
假設:
聯通 pppoe-out1 / pppoe-out2
電信 pppoe-out3 / pppoe-out4 / pppoe-out5 / pppoe-out6

依聯通100x2 / 電信20x4 比例匹配 ,所以pppoe1~pppoe6頻寬比為 5 : 5 : 1 : 1 : 1 : 1
除依定義視頻走聯通外,依餘的連線依比例配設pcc負載均衡:


/ip firewall mangle
add action=mark-routing chain=prerouting dst-address-list=video new-routing-mark=to_pppoe1 per-connection-classifier=src-port:2/0
add action=mark-routing chain=prerouting dst-address-list=video new-routing-mark=to_pppoe2 per-connection-classifier=src-port:2/1

add action=mark-routing chain=prerouting new-routing-mark=to_pppoe3 per-connection-classifier=src-port:14/0
add action=mark-routing chain=prerouting new-routing-mark=to_pppoe4 per-connection-classifier=src-port:14/1
add action=mark-routing chain=prerouting new-routing-mark=to_pppoe5 per-connection-classifier=src-port:14/2
add action=mark-routing chain=prerouting new-routing-mark=to_pppoe6 per-connection-classifier=src-port:14/3
add action=mark-routing chain=prerouting new-routing-mark=to_pppoe1 per-connection-classifier=src-port:2/0
add action=mark-routing chain=prerouting new-routing-mark=to_pppoe2 per-connection-classifier=src-port:2/1


/ip route
add distance=1 gateway=pppoe-out1 routing-mark=to_pppoe1
add distance=1 gateway=pppoe-out2 routing-mark=to_pppoe2
add distance=1 gateway=pppoe-out3 routing-mark=to_pppoe3
add distance=1 gateway=pppoe-out4 routing-mark=to_pppoe4
add distance=1 gateway=pppoe-out5 routing-mark=to_pppoe5
add distance=1 gateway=pppoe-out6 routing-mark=to_pppoe6



点评

我也是醉了。。。顺便提一下新版本 address-list 已经可以直接使用域名自动解析  发表于 2016-12-24 11:39
routeros
回复

使用道具 举报

发表于 2016-12-23 03:07:14 | 显示全部楼层
wssningzdm 发表于 2016-12-23 01:30
你的意思是电信主       联通用路由表 加 80  443 8080  ?

那客户端的DNS  主电信    备用联通?

CSPM333大神已经告诉你方法了,把需要转联通的加进表。DNS我用公共的。主电信或者主联通万一故障,基本解析都会出问题的。
routeros
回复

使用道具 举报

发表于 2016-12-23 03:13:53 | 显示全部楼层
cspm333 发表于 2016-12-23 02:53
在/system scheduler 新增網頁視頻script ,interval設00:00:20
轉換過的地址將存到/ip firewall address- ...

CSPM333兄弟,为什么电信的PCC要用14?还是手滑打错了?

我看到你PCC用的是src port,为什么不用both address呢?求教

点评

14不是只有電信,而是聯通+電信. 先把4/14的總頻寬分完,再分剩下的10/14. 剩下的10/14各用1/2分給兩筆聯通  发表于 2016-12-23 03:34
我想src-port 當變數"除"應該變化就足夠 ,當然both address數字加起來當變數"除"會變化的情況會更佳^^  发表于 2016-12-23 03:30
5 + 5 + 1 + 1 + 1 + 1 = 14  发表于 2016-12-23 03:27
routeros
回复

使用道具 举报

发表于 2016-12-23 03:40:20 | 显示全部楼层
zh1000000 发表于 2016-12-23 03:13
CSPM333兄弟,为什么电信的PCC要用14?还是手滑打错了?

我看到你PCC用的是src port,为什么不用bot ...

不是很明白,这个分法。我用我上次给你弄的做例子,你再分一下看看,我对比一下应该能看出为什么这样分。

例:电信50M+50M+50M联通12M+12M+12M.


我测试过,如果是src port,均分效果很好。但是测试所谓的443登陆问题没发现有问题。是不是同地址的缘故。

相对both就不用说了,大致都是用这个。多线情况下,这个未必每条线路都能均分。
routeros
回复

使用道具 举报

发表于 2016-12-23 03:42:39 | 显示全部楼层
按理解的层面
50+50+50看做为5
12+12+12看做为1

5+5+5+1+1+1=18这样理解对否
routeros
回复

使用道具 举报

发表于 2016-12-23 04:21:08 | 显示全部楼层
还有一个不理解的就是每组PCC参数后面的passthrough到底打勾还不不打勾,打勾的意思的什么?

点评

就是目前處裡的封包,還要留給下面的設定再做一次處理嗎? 做負載均衡時除非接下來沒有再進行均分的動作,千萬別勾選免得重複計算  发表于 2016-12-23 11:05
routeros
回复

使用道具 举报

发表于 2016-12-23 10:59:53 | 显示全部楼层
本帖最后由 cspm333 于 2016-12-23 11:31 编辑
zh1000000 發表於 2016-12-23 03:42
按理解的層面
50+50+50看做為5
12+12+12看做為1

不對, 5 : 5 : 5 : 1 : 1 : 1 是 50 : 50 : 50 : 10 : 10 : 10 時才這樣分.

50 : 50 :50 : 12 : 12 : 12 => 25 : 25 : 25 : 6 : 6 : 6(最大公因數是2)

所以我會先分3個1/25 ,剩餘的比就成 25 : 25 : 25 : 5 : 5 : 5
再約分變成5 : 5 : 5 : 1 : 1 : 1

所以再分3個1/18 ,這樣12M的部份就先均分完,等於先已處理18/93的部份.

剩於的75/93 (3個50M),再分成3等分,分一分就均分完啦^^


routeros
回复

使用道具 举报

发表于 2016-12-24 05:05:37 | 显示全部楼层
zh1000000 发表于 2016-12-23 04:21
还有一个不理解的就是每组PCC参数后面的passthrough到底打勾还不不打勾,打勾的意思的什么?

大概理解为,经过这个规则后数据还要不要继续往下的意思,对吗?
routeros
回复

使用道具 举报

发表于 2016-12-24 05:15:02 | 显示全部楼层
cspm333 发表于 2016-12-23 10:59
不對, 5 : 5 : 5 : 1 : 1 : 1 是 50 : 50 : 50 : 10 : 10 : 10 時才這樣分.

50 : 50 :50 : 12 : 12 :  ...

我反复看了这段好多遍,始终看不明白。93是怎么得到的。
然后总共要做9条PCC规则对吗?除了理解最后一组为0/3,1/3,2/3,开头和中间一头雾水。

点评

25x3+6x3=93 ,3條12m佔總頻寬的18/93  发表于 2016-12-24 10:21
routeros
回复

使用道具 举报

发表于 2016-12-24 11:30:56 | 显示全部楼层
本帖最后由 cspm333 于 2016-12-24 14:24 编辑
zh1000000 發表於 2016-12-24 05:15
我反覆看了這段好多遍,始終看不明白。93是怎麼得到的。
然後總共要做9條PCC規則對嗎?除了理解最後一組 ...

50 : 50 : 50 : 12 : 12 : 12 => 25 : 25 : 25 : 6 : 6 : 6 (總頻寬的分母是93)
所以總共9筆pcc ,

先配1/93 x3 => 93/93 - (1/93 x 3) = 90/93
再配5/93 x3 => 90/93 - (5/93 x 3) = 75/93
最後25/93 x3 => 75/93 - (25/93 x 3) = 0

#10樓的解釋方式有誤,這樣才正確.

所以先扣除3/93 後,變成90/93 (25 : 25 : 25 : 5 : 5 : 5)

這時就好約分的多,所以再約分成5 : 5 : 5 : 1 : 1 : 1
而1即代表扣3/93後,剩餘中的1/18(佔全部的5/93)

最後因12Mx3的部份全分配完,只剩50Mx3的部份沒動到,比例剩5 : 5 : 5 : 0 : 0 : 0
這時不再算比例了,反正剩餘的給3條50M的線路均分就對了.

所以9個pcc除數 ,
1-3要用93當除數 ,然後配給12M的pppoe-out
4-6要用18當除數 ,然後配給12M的pppoe-out
7-9要用3當除數 ,然後配給50M的pppoe-out

点评

看到这个帖子我还是很蒙圈。 比如我现在有2条电信30M/30M,一条联通200M,这种应该如何分啊? src-port:应该怎么写? 帮忙把计算过程再计算一下吧。  发表于 2022-12-14 00:51
routeros
回复

使用道具 举报

发表于 2016-12-25 09:58:01 | 显示全部楼层
cspm333 发表于 2016-12-23 02:53
在/system scheduler 新增網頁視頻script ,interval設00:00:20
轉換過的地址將存到/ip firewall address- ...

大神,膜拜一下,这个方案应该可行的!
routeros
回复

使用道具 举报

 楼主| 发表于 2016-12-29 06:14:15 | 显示全部楼层
cspm333 发表于 2016-12-23 02:53
在/system scheduler 新增網頁視頻script ,interval設00:00:20
轉換過的地址將存到/ip firewall address- ...

多谢大神  我现在用的是联通  电信都是PCC     只是把电信的线路 Passthrough 不打勾   然后在ROUTE 联通不做MARK
在NAT 做网通的DNS做DST-NAT到电信的DNS上,电信的PPPOE用户解析IP时,表面上是到网通的DNS解析,实际上还是在电信的DNS解析的IP


提醒:服务器和客户的DNS 都是联通  

点评

Passthrough 不打勾是正確的,尤其是定分配率時^^  发表于 2016-12-30 00:15
routeros
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由 ( 渝ICP备15001194号-1|渝公网安备 50011602500124号 )

GMT+8, 2024-5-31 02:43 , Processed in 0.093782 second(s), 5 queries , Gzip On, Redis On.

Powered by Discuz! X3.5 Licensed

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表