找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 20695|回复: 15

[策略设置] 抛砖引玉,说说曾经闹的火热的DSCP。很多搞游戏工作室关心的事。

[复制链接]
发表于 2013-12-5 00:47:32 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有账号?注册

×
本帖最后由 ksw520 于 2013-12-5 15:35 编辑

想实现,根据应用分流,一个游戏窗口一个IP的同志可以了解下。最近老有人问,也没时间一一回复,论坛也没啥新话题,发这里讨论下吧。
现在win7也普及了,虽然有很多局限性,某些环境下还是有一定意义。

win7客户端支持 根据进程名称 等一些条件做QOS策略。在winxp时代已经有不少产品开过客户端来实现。
一些对客户端有控制权的环境,可以方便的利用这个特性,简单的实现一些以往比较麻烦的需求。


win7的设置很简单,看图片吧

gpedit.msc
qos1.jpg (65.68 KB, 下载次数: 41)

qos2.JPG (102.11 KB, 下载次数: 4)

不重启电脑,使组策略生效可以用 gpupdate /force 命令。

routeros 里面的dscp就不用详述了,想必大家都了解。

/ip firewall mangle
add action=mark-routing chain=prerouting disabled=no dscp=1 new-routing-mark=ADSL2 passthrough=yes
add action=mark-routing chain=prerouting disabled=no dscp=2 new-routing-mark=ADSL2 passthrough=yes
add action=mark-routing chain=prerouting disabled=no dscp=3 new-routing-mark=ADSL3 passthrough=yes

没啥技术含量,仅抛砖引玉,希望有兴趣的朋友,研究后能和大家分享心得。
N年前的老话题,有时间再弄点新鲜的。

某些系统可设置组策略QOS无效。需要修改下注册表。
win7dscp.rar (324 Bytes, 下载次数: 75, 售价: 2 铜板)
routeros
发表于 2013-12-5 09:27:01 | 显示全部楼层
无图无真象, 我当个小白鼠先
routeros
回复

使用道具 举报

发表于 2013-12-5 09:28:33 | 显示全部楼层
这个用不到,留着备用吧,2个钢板,也不算多
routeros
回复

使用道具 举报

发表于 2013-12-5 09:55:00 | 显示全部楼层
Cos与Tos只是QoS的一种标记机制。
QoS范围太大,涉及到入口数据流的标记和分类及速率限制,网络骨干的拥塞避免和拥塞管理,网络出口的队列调度机制等等。
Cos是二层ISL或者802.1Q数据帧的优先级标记,3个bit,范围0-7;
Tos是三层数据包的服务类型标记,也是3个bit,范围0-7,同样可当作优先级标记,另外5个实际指示Delay,Throughput,Reliability等特性的bit位一般没有使用;
现在为了更好的控制数据流分类,使用DSCP(Differential Services Code Point),扩展了Tos的后三个bit,因此,范围从0-63。在实施QoS策略时,Cos与ToS或DSCP之间通常要做映射机制。
查询了一下资料,学习一下!@
routeros
回复

使用道具 举报

发表于 2013-12-5 11:46:22 | 显示全部楼层
本帖最后由 jike106397 于 2013-12-5 12:28 编辑

压缩文件要解压密码,是什么?

测试WINDOWS8,无论怎么配只,只对UDP部分数据包能正确标记,TCP的都无效.重启也是一样,不知道WINDOWS7
routeros
回复

使用道具 举报

 楼主| 发表于 2013-12-5 15:31:32 | 显示全部楼层
针对迅雷 优酷 这些视频网站分流 限速 都能搞定,包括那个一个游戏窗口一个外网IP的也能搞定。
用好了这个,那些搞网吧的就可以不用浪费精力折腾流控,分流BT下载就轻松用ROS实现。
routeros
回复

使用道具 举报

发表于 2013-12-10 16:14:24 | 显示全部楼层
要去客户端这样定义,企业级可能没问题。有域下发。但是很多都是只管网络的。适应性差。
routeros
回复

使用道具 举报

发表于 2013-12-10 16:23:07 | 显示全部楼层
还是在服务器端下工夫比较稳妥
routeros
回复

使用道具 举报

发表于 2014-2-5 08:43:25 | 显示全部楼层
本帖最后由 bill_deng 于 2014-2-5 08:44 编辑

DSCP正确用法。
我也抛一砖头,大多数的voip软件/设备会将其发出的数据包默认DSCP设为48, 如果你将 48 优先,你那些用voip的客户会谢谢你的。
但这里有一个问题,也是ipv4的问题,国为ipv4的网络基于互相信任的基础之上,那么,你怎么知道你收到的那些打着dscp48的数据包是你真正希望/以为的那些数据包呢?
routeros
回复

使用道具 举报

发表于 2015-9-15 19:58:27 | 显示全部楼层
看了下lz日志,貌似这是收山之作。

进程名这个都知道,还有那些条件呢,源端口是随机的,目标IP和端口虽然是固定的,但是如果两个游戏窗口的目标IP和端口都一样的话那怎么区分?
routeros
回复

使用道具 举报

发表于 2015-9-29 02:31:24 | 显示全部楼层
annn 发表于 2015-9-15 19:58
看了下lz日志,貌似这是收山之作。

进程名这个都知道,还有那些条件呢,源端口是随机的,目标IP和端口虽 ...

这个简单, 直接把游戏服务器的端口进行负载 例如NTH  这个我用的效果不错~
routeros
回复

使用道具 举报

发表于 2015-10-2 00:46:42 | 显示全部楼层
csj1314 发表于 2015-9-29 02:31
这个简单, 直接把游戏服务器的端口进行负载 例如NTH  这个我用的效果不错~

NTH, PCC 这些我都会,可是不能精确分配,比如ADSL1分到10个账号,而ADSL2就分到15个账号,或者从游戏一线换到二线的时候,出口也自动切换了
routeros
回复

使用道具 举报

发表于 2016-4-16 17:57:14 | 显示全部楼层
annn 发表于 2015-9-15 19:58
看了下lz日志,貌似这是收山之作。

进程名这个都知道,还有那些条件呢,源端口是随机的,目标IP和端口虽 ...

进程名前面是可以加路径的,你多开游戏的时候,放在不同目录下即可区分开来。。。
routeros
回复

使用道具 举报

发表于 2016-4-25 23:15:22 | 显示全部楼层
虽然不需要,还是谢谢了,要密码
routeros
回复

使用道具 举报

发表于 2017-12-28 02:22:00 | 显示全部楼层
密码呢密码呢
routeros
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由 ( 渝ICP备15001194号-1|渝公网安备 50011602500124号 )

GMT+8, 2024-4-20 15:49 , Processed in 0.100466 second(s), 10 queries , Gzip On, Redis On.

Powered by Discuz! X3.5 Licensed

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表