找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 12455|回复: 6

[其它] 已解决:看来又得再折腾了。ROS5.18升级到5.20后,DDNS用不了了。

[复制链接]
发表于 2012-9-24 08:12:57 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有账号?注册

×
本帖最后由 kzyfl 于 2012-9-28 12:26 编辑

已解决,半个月都没远程了,现在终于搞成了,不是网卡聚合问题,也不是升级到5.20的问题,是DDNS动态域名自动被删除了,手动添加上去,现在好了。
真郁闷,正常用的二级域名,说删就删,在这里谴责一下。www.changeip.com



# HomingBeacon Main Dynamic DNS Update Script
# Written by Sam Norris, ChangeIP.com
# 20100728 Tested on routeros 4.9
# 20110511 Tested on RouterOS 5.2

# Set your specific ChangeIP.com preferences here.
:global ddnsuser "用户名"
:global ddnspass "密码"
:global ddnshost "域名"
# Change ddnsport to 8245 to bypass proxy.
:local ddnsport 80

# Do not edit anything below this line.  You have been warned.
# Abusive updates to the system will cause firewall blocks.

# Please be considerate and
# do not let this script run more than once per 3-5 minutes.

:log info "DDNS: Starting."

# Initialize checkpoint
:global ddnscheckpoint
:if ([:typeof $ddnscheckpoint] = "time") do={
        :log info ("DDNS: Last check was " . ([/system clock get time] - $ddnscheckpoint))
} else={
        :log info "DDNS: Cannot determine checkpoint, set now."
        :global ddnscheckpoint ( [/system clock get time] - 1d )
}

# Get the current IP
:if ([/system clock get time] - $ddnscheckpoint > [:totime 180s] || [/system clock get time] - $ddnscheckpoint < [:totime 0s]) do={
   :log info "DDNS: Performing remote IP detection."
   /tool fetch address="ip.changeip.com" host="ip.changeip.com" src-path=("/?" . [/int eth get 0 mac-address ]) dst-path="ip.changeip.com.txt" mode=http port=$ddnsport
   :global ddnscheckpoint [/system clock get time]
} else={
   :log info "DDNS: Please be considerate and wait a few seconds longer."
   :break
}

# Parse the IP address received from fetch script.
        :global ddnslastip
        :local html [/file get "ip.changeip.com.txt" contents]
        :local ddnsip [:pick $html ([:find $html "<!--IPADDR="] + 11) [:find $html "-->"] ]

# Is it a valid IP and is it different than the last one?
        :if ([:typeof [:toip $ddnsip]] = "ip" AND $ddnsip != $ddnslastip ) do={
                :log info "DDNS: Sending UPDATE with $ddnsip"
                :log info [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ]
                :global ddnslastip $ddnsip
        } else={
                :log info "DDNS: No update required."
        }
}
routeros
发表于 2012-9-24 10:04:02 | 显示全部楼层
脚本有问题....
routeros
回复

使用道具 举报

 楼主| 发表于 2012-9-24 16:59:17 | 显示全部楼层
routeros
回复

使用道具 举报

 楼主| 发表于 2012-9-28 09:29:19 | 显示全部楼层
问题更难琢磨了.我把版本还原到5.18,还是不行。最近就动过两次ROS,一次是升级到ROS 5.20,另一次是增加一块内网网卡,做双网卡bonding,用的是:balance-xor 模式。不会是内网网卡绑定引起的DDNS不能正常使用吧。
routeros
回复

使用道具 举报

 楼主| 发表于 2012-9-28 10:31:35 | 显示全部楼层
本帖最后由 kzyfl 于 2012-9-28 10:40 编辑
sffqqq 发表于 2012-9-24 10:04
脚本有问题....


脚本本身应该没问题吧。原来一直用的正常,只是设定了双网卡内网聚合和升级到5.20后才出的问题,现在还原到ROS5。18了。这个DDNS的原理是,在ROS FTP根目录下建创建个记事本文件,ip.changeip.com.txt,如果外线PPPOE接口中的默认端口IP有变化,就更改记事本文件里面的IP值,然后通过脚本使二级域名绑记事要里面的IP,我测试过了,可以正常更新记事本里面的IP,就是不可以正常读取IP。记事本里面的内容为:123.14.58.111<!--IPADDR=123.14.58.111-->
付更新IP日志图: ddns.jpg
routeros
回复

使用道具 举报

发表于 2013-3-16 12:04:10 | 显示全部楼层
如果没记错,如果你半年没有登陆changeip网站,就会删除你帐户下的域名(免费用户),且删除前会有邮件提醒
routeros
回复

使用道具 举报

发表于 2013-3-16 12:14:27 | 显示全部楼层
一般都没有问题,多到changeip.net查查更新记录。现几乎每月都有问题,说1小时恢复有可能要半天。

temp.jpg
routeros
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由 ( 渝ICP备15001194号-1|渝公网安备 50011602500124号 )

GMT+8, 2024-11-23 19:01 , Processed in 0.056004 second(s), 5 queries , Gzip On, Redis On.

Powered by Discuz! X3.5 Licensed

© 2001-2024 Discuz! Team.

快速回复 返回顶部 返回列表