找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 24323|回复: 20

[脚本] ROS3.3,ADSL双线,VRRP多拨,同网关和不同网关,PCC,成功啦,有图哟

  [复制链接]
发表于 2011-10-12 00:09:04 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有账号?注册

×
本帖最后由 ww111222 于 2011-10-12 00:38 编辑

俺的环境 有些怪:


  一条电信10M光纤 ADSL ,一个账号, 可多拨。  得到的IP 是同网关。

  一条 联通4M ADSL ,一个账号,可多拨。得到的IP也是同网关(当然不和电信的网关相同啦),




今天测试了一下,  用pcc 3线 负载。


  2条 光纤 ADSL,一条 联通ADSL,


下载有 1.4M 左右。


  得出一个结论,  我这里虽然支持多拨,但一条线的总带宽 已经限制, 所以,和单拨没有区别。


  主要是为了测试 多线 PCC。
















剪贴板-1.jpg






剪贴板-2.jpg



脚本 没有 用 循环,不好意思,后期准备再 优化一下。
  1. #===================================================================================
  2. # 多线同网关 PCC 负载
  3. #===================================================================================
  4. #        思路:先标记 连接,再标记路由,再添加路由,再伪装。





  5. #===================================================================================
  6. # 标记 连接和路由
  7. #===================================================================================
  8. #        先标记一个连接,并做PCC,再标记这个连接的路由,注意:路由标记的passthrough为no
  9. #
  10. #        变量        InInterface        内网网卡名称


  11. :global InInterface "LAN"

  12. /ip firewall mangle
  13. add chain=prerouting \
  14.         in-interface=$InInterface \
  15.         action=mark-connection \
  16.         new-connection-mark="conn_1st" \
  17.         per-connection-classifier=src-address-and-port:3/0 \
  18.         passthrough=yes \
  19.         comment="PCC\CB\AB\CF\DF\B8\BA\D4\D8" \
  20.         disable=no

  21. add chain=prerouting \
  22.         in-interface=$InInterface \
  23.         connection-mark="conn_1st" \
  24.         action=mark-routing \
  25.         new-routing-mark="route_1st" \
  26.         passthrough=no \
  27.         disable=no
  28.        

  29. /ip firewall mangle
  30. add chain=prerouting \
  31.         in-interface=$InInterface \
  32.         action=mark-connection \
  33.         new-connection-mark="conn_2st" \
  34.         per-connection-classifier=src-address-and-port:3/1 \
  35.         passthrough=yes \
  36.         disable=no

  37. add chain=prerouting \
  38.         in-interface=$InInterface \
  39.         connection-mark="conn_2st" \
  40.         action=mark-routing \
  41.         new-routing-mark="route_2st" \
  42.         passthrough=no \
  43.         disable=no
  44.        
  45. /ip firewall mangle
  46. add chain=prerouting \
  47.         in-interface=$InInterface \
  48.         action=mark-connection \
  49.         new-connection-mark="conn_3st" \
  50.         per-connection-classifier=src-address-and-port:3/2 \
  51.         passthrough=yes \
  52.         disable=no

  53. add chain=prerouting \
  54.         in-interface=$InInterface \
  55.         connection-mark="conn_3st" \
  56.         action=mark-routing \
  57.         new-routing-mark="route_3st" \
  58.         passthrough=no \
  59.         disable=no

  60. #===================================================================================
  61. # 路由设置
  62. #===================================================================================
  63. #        先添加主路由,再添加备用路由
  64. #
  65. #       


  66. # 配置主路由
  67. /ip route
  68. add dst-address=0.0.0.0/0 \
  69.         gateway="adsl-1-pppoe-out101" \
  70.         check-gateway=ping \
  71.         type=unicast \
  72.         distance=1 \
  73.         scope=30 \
  74.         target-scope=10 \
  75.         routing-mark="route_1st" \
  76.         comment="ADSL-\B2\A6\BA\C5\D6\F7\C2\B7\D3\C9" \
  77.         disable=no
  78.        
  79. add dst-address=0.0.0.0/0 \
  80.         gateway="adsl-1-pppoe-out102" \
  81.         check-gateway=ping \
  82.         type=unicast \
  83.         distance=1 \
  84.         scope=30 \
  85.         target-scope=10 \
  86.         routing-mark="route_2st" \
  87.         disable=no

  88. add dst-address=0.0.0.0/0 \
  89.         gateway="pppoe-4M" \
  90.         check-gateway=ping \
  91.         type=unicast \
  92.         distance=1 \
  93.         scope=30 \
  94.         target-scope=10 \
  95.         routing-mark="route_3st" \
  96.         disable=no

  97. # 配置备用路由
  98. /ip route
  99. add dst-address=0.0.0.0/0 \
  100.         gateway="adsl-1-pppoe-out101" \
  101.         check-gateway=ping \
  102.         type=unicast \
  103.         distance=2 \
  104.         scope=30 \
  105.         target-scope=10 \
  106.         comment="ADSL-\B2\A6\BA\C5\B1\B8\D3\C3\C2\B7\D3\C9" \
  107.         disable=no
  108.        
  109. add dst-address=0.0.0.0/0 \
  110.         gateway="adsl-1-pppoe-out102" \
  111.         check-gateway=ping \
  112.         type=unicast \
  113.         distance=2 \
  114.         scope=30 \
  115.         target-scope=10 \
  116.         disable=no

  117. add dst-address=0.0.0.0/0 \
  118.         gateway="pppoe-4M" \
  119.         check-gateway=ping \
  120.         type=unicast \
  121.         distance=2 \
  122.         scope=30 \
  123.         target-scope=10 \
  124.         disable=no


  125. #===================================================================================
  126. # NAT 伪装设置
  127. #===================================================================================
  128. #        对每个 pppoe 连接 做伪装
  129. #
  130. #

  131. /ip firewall nat
  132. add chain=srcnat \
  133.         out-interface="adsl-1-pppoe-out101" \
  134.         action="masquerade" \
  135.         comment="ADSL\CB\AB\CF\DF\CE\B1\D7\B0" \
  136.         disable=no
  137.        
  138. add chain=srcnat \
  139.         out-interface="adsl-1-pppoe-out102" \
  140.         action="masquerade" \
  141.         disable=no

  142. add chain=srcnat \
  143.         out-interface="pppoe-4M" \
  144.         action="masquerade" \
  145.         disable=no





















复制代码
我是从 这个教程 做出来的。




ROS3_30 ADSL双线 同网关 PCC及NTH负载均衡图文教程.jpg
routeros
发表于 2011-10-12 18:25:12 | 显示全部楼层
顶下你
routeros
回复

使用道具 举报

发表于 2011-10-26 20:46:52 | 显示全部楼层
要么不看,看了一定得帮顶,不管好坏,都发了心思的。
routeros
回复

使用道具 举报

发表于 2011-10-26 21:54:08 | 显示全部楼层
期待多条线路测试
routeros
回复

使用道具 举报

发表于 2011-10-26 22:00:26 | 显示全部楼层
应该加分
routeros
回复

使用道具 举报

发表于 2011-11-6 02:24:21 | 显示全部楼层
照理说,ISP不会限制物理的端口的,其实楼主的多博没成功啊;或者你当地的ISP不支持的
routeros
回复

使用道具 举报

发表于 2011-11-9 10:00:14 | 显示全部楼层
  1. [list]
  2. [*]111
  3. [/list][table=50%]
  4. [tr][td] [/td][td] [/td][/tr]
  5. [tr][td] [/td][td] [/td][/tr]
  6. [/table]
复制代码
routeros
回复

使用道具 举报

发表于 2011-11-9 10:02:28 | 显示全部楼层


1
2
3
routeros
回复

使用道具 举报

发表于 2011-11-9 10:02:56 | 显示全部楼层
  1. 1
  2. 2
  3. 3
  4. 4
复制代码
routeros
回复

使用道具 举报

发表于 2011-11-9 14:18:11 | 显示全部楼层
是不是啊...........
routeros
回复

使用道具 举报

发表于 2011-11-10 12:09:56 | 显示全部楼层
谢谢分享,在学习当中
routeros
回复

使用道具 举报

发表于 2011-11-10 13:23:55 | 显示全部楼层
看了一定得帮顶
routeros
回复

使用道具 举报

发表于 2011-11-11 14:28:53 | 显示全部楼层
你果断的是给力啊。
routeros
回复

使用道具 举报

发表于 2011-11-12 00:18:05 | 显示全部楼层
这个要好好看下了。
routeros
回复

使用道具 举报

发表于 2011-12-16 18:09:25 | 显示全部楼层
支持,严重支持,顶了先
routeros
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由 ( 渝ICP备15001194号-1|渝公网安备 50011602500124号 )

GMT+8, 2024-11-23 15:24 , Processed in 0.105032 second(s), 5 queries , Gzip On, Redis On.

Powered by Discuz! X3.5 Licensed

© 2001-2024 Discuz! Team.

快速回复 返回顶部 返回列表