自由的生活_软路由

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 61822|回复: 89

[策略设置] ros双线叠加+负载均衡(一定要顶)

  [复制链接]
发表于 2009-2-26 00:20:10 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有账号?注册

x
各位好:
    先谢谢教我的各位,
    先吹吹我自己,我自己并不是学电脑专业的,只是个业余者,先前发布了多线分流教程,发现有N多朋友加我,和我一起学习,
当然也通过远程,也挣来不少Q币,不过都送人了,今天没有事做,做个双线负载视频教程,以教程会朋友,当然我已经说了
自己是个菜菜鸟,大师就不要见笑了。呵呵
       好,现在开始做教程。
    用到的一个工具,RouteROS脚本生成器.exe
    先看一下效果
    2。9。27版本,
好了,谢谢大家了。



ADSL
动态IP自动找到
:local assign-address
:local new-address
:local status
:local x
:set x 2
:for i from=1 to=$x do={
    :set status [/interface get [/interface find  name=("pppoe-out" . $i)] running]
    :if ($status=true) do={
     :set new-address [/ip address get [/ip address find dynamic=yes interface=("pppoe-out" . $i)] address]
     :set new-address [:pick $new-address 0 ([:len $new-address] -3)]
     :set assign-address [/ip address get [/ip address find dynamic=no interface=("pppoe-out" . $i)] address]
     :set assign-address [:pick $assign-address 0 ([:len $assign-address] -3)]
        :if ($assign-address != $new-address) do={ /ip address set [/ip address find comment=$i] address=$new-address network=$new-address broadcast=$new-address
        /ip route set [/ip route find comment=$i] gateway=$new-address
        /ip fir nat set [/ip fir nat find comment=$i] to-addresses=$new-address
        /ip route set [/ip route find comment=$i] gateway=$new-address
       }
   }
}




双线+LAN+IP
/ip address add address=192.168.0.1/255.255.255.0 interface=lan comment=lan
/ip dns set primary-dns=202.96.134.133 secondary-dns=202.96.128.68 allow-remote-requests=yes
/ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn action=change-mss new-mss=1440
/interface pppoe-client add name="pppoe-out1" interface=wan1 user="123" password="123" add-default-route=no disabled=no
/interface pppoe-client enable pppoe-out1
/ip address add address=58.58.58.1/32 interface=pppoe-out1 comment="1"
/ip route add gateway=58.58.58.1 routing-mark=1 comment="1"
/ip firewall mangle add chain=prerouting in-interface=lan connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=1 passthrough=yes disabled=no
/ip firewall mangle add chain=prerouting in-interface=lan connection-mark=1 action=mark-routing new-routing-mark=1 passthrough=no disabled=no
/ip firewall nat add chain=srcnat connection-mark=1 action=src-nat to-addresses=58.58.58.1 to-ports=0-65535 comment="1" disabled=no
/interface pppoe-client add name="pppoe-out2" interface=wan2 user="456" password="456" add-default-route=no disabled=no
/interface pppoe-client enable pppoe-out2
/ip address add address=58.58.58.2/32 interface=pppoe-out2 comment="2"
/ip route add gateway=58.58.58.2 routing-mark=2 comment="2"
/ip firewall mangle add chain=prerouting in-interface=lan connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=2 passthrough=yes disabled=no
/ip firewall mangle add chain=prerouting in-interface=lan connection-mark=2 action=mark-routing new-routing-mark=2 passthrough=no disabled=no
/ip firewall nat add chain=srcnat connection-mark=2 action=src-nat to-addresses=58.58.58.2 to-ports=0-65535 comment="2" disabled=no

ros双线叠加 负载分流.part21.rar

417.54 KB, 下载次数: 1417

ros双线叠加 负载分流.part01.rar

1.39 MB, 下载次数: 1656

ros双线叠加 负载分流.part02.rar

1.39 MB, 下载次数: 1598

ros双线叠加 负载分流.part03.rar

1.39 MB, 下载次数: 1487

ros双线叠加 负载分流.part04.rar

1.39 MB, 下载次数: 1589

ros双线叠加 负载分流.part05.rar

1.39 MB, 下载次数: 1461

ros双线叠加 负载分流.part06.rar

1.39 MB, 下载次数: 1532

ros双线叠加 负载分流.part07.rar

1.39 MB, 下载次数: 1452

ros双线叠加 负载分流.part08.rar

1.39 MB, 下载次数: 1459

ros双线叠加 负载分流.part09.rar

1.39 MB, 下载次数: 1418

ros双线叠加 负载分流.part10.rar

1.39 MB, 下载次数: 1475

ros双线叠加 负载分流.part11.rar

1.39 MB, 下载次数: 1447

ros双线叠加 负载分流.part12.rar

1.39 MB, 下载次数: 1391

ros双线叠加 负载分流.part13.rar

1.39 MB, 下载次数: 1398

ros双线叠加 负载分流.part14.rar

1.39 MB, 下载次数: 1406

ros双线叠加 负载分流.part15.rar

1.39 MB, 下载次数: 1393

ros双线叠加 负载分流.part16.rar

1.39 MB, 下载次数: 1400

ros双线叠加 负载分流.part17.rar

1.39 MB, 下载次数: 1396

ros双线叠加 负载分流.part18.rar

1.39 MB, 下载次数: 1394

ros双线叠加 负载分流.part19.rar

1.39 MB, 下载次数: 1338

ros双线叠加 负载分流.part20.rar

1.39 MB, 下载次数: 1445

routeros
发表于 2009-2-26 09:13:19 | 显示全部楼层
先不看了, 顶了再说
routeros
回复 支持 0 反对 1

使用道具 举报

 楼主| 发表于 2009-2-26 12:30:03 | 显示全部楼层
大家要顶起来啊,
routeros
回复 支持 1 反对 0

使用道具 举报

发表于 2009-2-26 06:10:33 | 显示全部楼层
为了方便坛友下载,本人把教程打包了,http://www.bibidu.com/fileview-1115009.html
routeros
回复 支持 0 反对 1

使用道具 举报

发表于 2009-2-26 05:29:09 | 显示全部楼层
不错,就是包分得太多了,支持共享
routeros
回复 支持 0 反对 1

使用道具 举报

 楼主| 发表于 2009-2-26 12:28:32 | 显示全部楼层
不知道版主能否加精,让我作为记录。看看能否把文件全部打包在一起,这样下载也方便一点。
不知道版主能否加精,让我作为记录。看看能否把文件全部打包在一起,这样下载也方便一点。
不知道版主能否加精,让我作为记录。看看能否把文件全部打包在一起,这样下载也方便一点。
不知道版主能否加精,让我作为记录。看看能否把文件全部打包在一起,这样下载也方便一点。
routeros
回复 支持 1 反对 0

使用道具 举报

发表于 2009-2-26 09:32:26 | 显示全部楼层
支持共享
routeros
发表于 2009-2-26 09:49:37 | 显示全部楼层
routeros
发表于 2009-3-1 22:48:49 | 显示全部楼层
顶起 学习一下
routeros
发表于 2009-3-7 20:14:01 | 显示全部楼层
学习学习
routeros
 楼主| 发表于 2009-3-11 00:28:27 | 显示全部楼层
:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol:lol
routeros
发表于 2009-3-11 03:16:50 | 显示全部楼层
运气好的没话说。。先收藏下,目前没环境测试,不知道有环境的朋友测试过没有,是否OK?
routeros
发表于 2009-3-13 16:07:22 | 显示全部楼层
有空学习试下
routeros
发表于 2009-3-14 16:07:36 | 显示全部楼层
顶一下,先
呵呵
routeros
发表于 2009-3-14 18:13:04 | 显示全部楼层
强烈顶 楼主 还有 3楼的 我快下完了 不知道能不能成功 倒时候告诉大家 呵呵
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2023-2-6 08:19 , Processed in 0.065703 second(s), 19 queries , Gzip On, MemCached On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表