自由的生活_软路由

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 121|回复: 0

[基础] Nat日志配置及功能介绍

[复制链接]
发表于 2022-11-16 14:20:35 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有账号?注册

x
本帖最后由 sealin 于 2022-11-16 14:26 编辑

Nat日志功能配置

Nat日志可解析RouteROS(ROS系统)全链路日志

Nat日志已支持RouterOS全链路日志,包括SrcNat、DstNat、InPut、OutPut、Forward、Prerouting、Postrouting,请根据您的需求自行修改下方部署脚本; 也可以在ip\firewall下mangle、filter、nat、raw里的任意规则,都可以启用log,RosZ会解析存储对应日志数据。


                               
登录/注册后可看大图

Nat日志Winbox配置

启用Nat日志
启用全日志后,执行以下指令,启用SrcNat和DstNat规则的log功能,记录Nat日志。
{/ip firewall nat
set [find action=masquerade chain=srcnat log=no] log=yes
set [find chain=dstnat log=no] log=yes}



日志启用配置十分灵活,您可以根据自己RouterOS系统配置,自行调整,示例仅供参考。启用log功能即可实现日志解析和收录,十分方便。

关闭Nat日志
{/ip firewall nat
set [find action=masquerade chain=srcnat log=yes] log=no
set [find chain=dstnat log=yes] log=no}

关闭Nat日志即取消log输出功能。

RouterOS日志配置建议
  • 建议把RouterOS的内置DNS服务器启用,并在DHCP、PPP等功能中,默认为用户下发首选DNS为该服务(备用可用公共DNS),以便日志中的域名反查信息更准确;
  • 设备比较多时,可以使用【云指令】功能,快速操作启用和关闭Nat日志功能;
  • 历史域名为日志发生时的域名数据快照存档信息,检索关键字也匹配该数据;站点域名是当前最新的域名信息,不在检索范围,如需精准检索可以使用对应的ip;最新和历史数据同时展示,方便比对,及时发现异常流量;
  • 建议X86、CHR、中高端设备,在【日志告警-功能管理】界面切换至SFTP模式。UDP模式,使用514端口实时传输日志数据,无重传能力,丢失率与网络质量成反比,实测丢失率均值0.05%,适合磁盘容量有限的低端设备; SFtp模式,使用50022端口SFtp加密协议同步日志数据,设备本地使用文件缓存,断流自动重传,可实现0丢失,适合中高端设备或有日志0丢失要求的业务;

Nat日志界面介绍
Nat日志界面功能丰富,具体参考下发界面功能图示。
右上角自选列功能每个页面都可以控制,自选列自动保存在本地浏览器缓存中。
表头支持拖拽,可快速改变列排序。
另外,所有页面均支持导出Excel和打印功能。
Nat日志界面功能不断丰富完善中,教程可能有延迟,以最新界面为准。

                               
登录/注册后可看大图

Nat日志界面介绍

日志地理分布显示功能
点击查看日志地理分布,会根据当前检索关键字及日志库数据,在地图上展示日志地理分布。
可分别查看来源归属地、目的归属地的日志地理分布情况。

                               
登录/注册后可看大图

日志地理分布显示功能

多维度数据汇聚功能
Nat日志的大部分字段均支持汇聚分析功能,可点击字段前的“>”标记,弹出汇聚数据子表,支持多开,便于对比分析。

                               
登录/注册后可看大图

多维度数据汇聚功能

IP定位功能
定位精度不高,仅供参考。

                               
登录/注册后可看大图

IP定位功能

数据解析功能
支持以下四类数据解析:
  • IP归属地解析
  • IP反查域名
  • 域名备案信息解析
  • radius计费认证账号关联解析

日志分类及记录状态
日志记录状态详细显示日志磁盘占用情况,并自动计算6个月保存消耗。
如资源不足,请联系站长补充资源包。

                               
登录/注册后可看大图

日志分类及记录状态


原文地址:https://blog.rosz.cn/?p=218



routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2022-11-28 03:55 , Processed in 0.040346 second(s), 15 queries , Gzip On, MemCached On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表