自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 684|回复: 7

[脚本] 帮忙改个脚本运行脚本后给微信发消息

[复制链接]
发表于 2020-12-21 21:38:50 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
###通知微信ID###  
:local appToken "AT_WzXNLEBDoG2FIn5nh*********"
:local uid "UID_psthEWlB7zRiJKwpS6zqq*******"  
:local content "基站OLT(172.19.169.3)设备已恢复"  
###开启接口回显(yes/no)###
:local debug "no"
:do {/tool fetch url=("http://wxpusher.zjiecode.com/api/send/message/?appToken=$appToken&content=$content&uid=$uid") mode=http keep-result=$debug dst-path=wx.log}
:delay 3s;
:if ([/file find name="wx.log"] !="") do={:log warning [/file get [find name="wx.log"] contents];/file remove [find name="wx.log"]}


上面是根据下面的接口例子改的
自己在IE 上运行 可以接收微信信息  在ROS 运行不行
请帮忙改下 ,谢谢


GET接口举例
http://wxpusher.zjiecode.com/api/send/message/?appToken=AT_qHT0cTQfLwYOlBV9cJj9zDSyEmspsmyM&content=123&uid=c1BcpqxEbD8irqlGUh9BhOqR2BvH8yWZ











routeros
发表于 2020-12-22 00:04:55 | 显示全部楼层
瞎猜的,ros设置了dns了麽
routeros
 楼主| 发表于 2020-12-22 08:31:19 | 显示全部楼层
seignior 发表于 2020-12-22 00:04
瞎猜的,ros设置了dns了麽

dns设置了 能解析
routeros
发表于 2020-12-23 11:32:27 | 显示全部楼层
  1. {
  2. ###通知微信ID###  
  3. :local appToken "AT_WzXNLEBDoG2FIn5nh*********"
  4. :local uid "UID_psthEWlB7zRiJKwpS6zqq*******"  
  5. :local content "基站OLT(172.19.169.3)设备已恢复"  
  6. ###开启接口回显(yes/no)###
  7. :local debug "yes"
  8. :do {/tool fetch url=("http://wxpusher.zjiecode.com/api/send/message/\?appToken=$appToken&content=$content&uid=$uid") mode=http keep-result=$debug dst-path=wx.log} on-error={ }
  9. :delay 3s;
  10. :if ([/file find name="wx.log"] !="") do={:log warning [/file get [find name="wx.log"] contents];/file remove [find name="wx.log"]}
  11. }
复制代码


大概是这样
routeros
发表于 2021-1-3 14:17:52 | 显示全部楼层
我测试了一下有两个问题   1貌似不能支持ros  编码不一样 ,2 不支持上传文件   / 直接发英文字母可以
routeros
发表于 2021-1-3 21:30:20 | 显示全部楼层
小白充大神 发表于 2021-1-3 14:17
我测试了一下有两个问题   1貌似不能支持ros  编码不一样 ,2 不支持上传文件   / 直接发英文字母可以 ...

http://ros6.com/?action=show&id=238
可以支持中文

routeros
 楼主| 发表于 2021-1-9 13:51:00 | 显示全部楼层
小白充大神 发表于 2021-1-3 14:17
我测试了一下有两个问题   1貌似不能支持ros  编码不一样 ,2 不支持上传文件   / 直接发英文字母可以 ...

中文用urlEncode编码就可以了!
routeros
发表于 2021-1-10 14:56:28 | 显示全部楼层
本帖最后由 小白充大神 于 2021-1-10 15:00 编辑

的确如此,转码即可支持发送中文,直接发送中文不成功! 谢楼上各位
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2021-1-28 19:53 , Processed in 0.259900 second(s), 22 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表