自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 585|回复: 4

[脚本] Netwatch 多线路检测ping切换如何使用?

[复制链接]
发表于 2020-7-3 17:26:01 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
例如 A线路的IP地址是1.1.1.100,默认网关是1.1.1.1 ;       B线路的IP地址是2.2.2.100,默认网关是2.2.2.2;

通过源地址1.1.1.100去ping 114.114.114.114 ,如果断了切换2.2.2.100的出口。
如果源地址1.1.1.100去ping 114.114.114.114恢复通讯,将自动切换回1.1.1.100

这个可以做到不?





routeros
发表于 2020-7-3 19:39:31 | 显示全部楼层
本帖最后由 cspm333 于 2020-7-3 20:10 编辑

一般的script可以,用排程定時執行即可;
而netwatch無法指定wan接口,透過netwatch反而辦不到。

#script:
  1. :local check ([/ping 114.114.114.114 src-address=1.1.1.100 count=2]>0)
  2. :local id [/ip route find dst-address=0.0.0.0/0 distance=1 [:typeof $"routing-mark"]="nil"]
  3. :local gw [/ip route get $id gateway]
  4. :if ($check && $gw="2.2.2.2") do={/ip route set $id gateway=1.1.1.1}
  5. :if (!$check && $gw="1.1.1.1") do={/ip route set $id gateway=2.2.2.2}
复制代码


routeros
发表于 2020-7-3 20:29:26 | 显示全部楼层
本帖最后由 cspm333 于 2020-7-3 21:16 编辑

或者根本不需要ping與script,透過路由表優先權(distance)解決。

/ip route
add gateway=1.1.1.1 distance=1
add gateway=2.2.2.2. distance=2

若權1 gateway正常,路由從1.1.1.100出;
若權1不正常,則由權2 (2.2.2.100)遞補,直至權1 (1.1.1.100)重回優先為止。
routeros
发表于 2020-7-4 08:52:14 | 显示全部楼层
/ip route
add check-gateway=ping distance=1 gateway=192.168.1.1
routeros
发表于 2020-7-6 10:19:02 | 显示全部楼层
本帖最后由 xuxi3201 于 2020-7-6 12:49 编辑

入门用户:
/ip route
add check-gateway=ping distance=1 gateway=192.168.1.1



初级用户:
/ip route
add check-gateway=ping comment=A distance=10 gateway=192.168.1.1
add check-gateway=ping comment=B distance=20 gateway=192.168.2.1

tools菜单下面netwatch增加一个
host行: 114.114.114.114
down栏目
:foreach aaa in=[/ip route find comment=A] do={/ip route set $aaa distance=30}

tools菜单下面netwatch增加第二个
host行: 192.168.1.1
up栏目
:foreach aaa in=[/ip route find comment=A] do={/ip route set $aaa distance=10}



中级用户:
做 /ip route set $aaa distance=30 检查,如果已经存在,就不改写
做 /ip route set $aaa distance=10 检查,如果已经存在,就不改写
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2020-8-4 19:40 , Processed in 0.151113 second(s), 22 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表