自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 328|回复: 3

[脚本] ROS云变量

[复制链接]
发表于 2020-6-16 21:47:46 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 9939781 于 2020-6-16 21:48 编辑

浏览器直接打开(https://mail.ros6.com:5656/newtoken)可获取一个新的安全token,用于后面鉴权。

###更新/新增变量示例###
:local testbl "test测试"
###以下token请自行修改###

:local mycvtoken "dIzvnKB8ests"
[/tool fetch url="https://mail.ROS6.com:5656/update&testbl=$testbl" check-certificate=no as-value output=user http-header-field=("Token:".$mycvtoken)]

###获取变量示例###
###以下token请自行修改###
:local mycvtoken "dIzvnKB8ests"
:local result [/tool fetch url="https://mail.ros6.com:5656/get&testbl" check-certificate=no as-value output=user http-header-field=("Token:".$mycvtoken)]
:if ($result->"status" = "finished") do={
:global gettestbl ($result->"data")
:log warning $gettestbl
}

某些情况ROS的变量需要跨设备调用,就会需要用到。剩下的大家自由发挥。
免费,免注册,开放使用。


routeros
发表于 2020-6-17 09:20:26 | 显示全部楼层
66666  这功能不错  可以用于vpn连接 毕竟域名有缓存
routeros
发表于 2020-6-18 20:49:33 | 显示全部楼层
这个厉害,是不是以后我这块得到的数据,就可以在其它设备上直接使用。
routeros
 楼主| 发表于 2020-6-19 12:02:33 | 显示全部楼层
57068368 发表于 2020-6-18 20:49
这个厉害,是不是以后我这块得到的数据,就可以在其它设备上直接使用。

是的哟。
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2020-7-8 18:00 , Processed in 0.138123 second(s), 22 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表