自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 344|回复: 6

[其它] 关于三层请教一个问题

[复制链接]
发表于 2020-6-16 18:38:45 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
我ping   192.168.207.1显示如下:
ROS2020-0616.jpg
三层设备 不归我管。

请问:
我有没有办法指定一条路由?
目标 192.168.207.0/24
网关 10.2.2.2

routeros
发表于 2020-6-16 19:56:58 | 显示全部楼层
在/ip route新增:
add dst-address=192.168.207.0/24 gateway=10.2.2.2 distance=8

只是在script內動作,
透過ping判斷連線的vpn有沒有斷開,不去修改路由表的作法。假設:

vpn-name:sstp-out1
vpn-local-address:10.2.2.1
vpn-remote-address:10.2.2.2

方法1(指定interface):
/put ([/ping 192.168.207.1 count=2 interface=sstp-out1]>0)

方法2(本地地址):
/put ([/ping 192.168.207.1 count=2 src-address=10.2.2.1]>0)

方法3(使用標記):
/put ([/ping 192.168.207.1 count=2 routing-table="to_sstp-out1"]>0)



routeros
发表于 2020-6-18 20:45:40 | 显示全部楼层
cspm333 发表于 2020-6-16 19:56
在/ip route新增:
add dst-address=192.168.207.0/24 gateway=10.2.2.2 distance=8

add dst-address=192.168.207.0/24 gateway=10.2.2.2 distance=8


这条应该不会升效吧。






点评

當然有用,不然您覺得distance這變數該用在什麼地方  发表于 2020-6-18 21:20
routeros
发表于 2020-6-24 17:48:59 | 显示全部楼层
57068368 发表于 2020-6-18 20:45
add dst-address=192.168.207.0/24 gateway=10.2.2.2 distance=8

这条应该不会升效吧。

本地接口上没有与10.2.2.2相通的地址,应该不能生效吧。
routeros
发表于 2020-6-24 22:21:16 | 显示全部楼层
57068368 发表于 2020-6-24 17:48
本地接口上没有与10.2.2.2相通的地址,应该不能生效吧。

a.png
routeros
发表于 2020-6-25 14:39:17 | 显示全部楼层

厉害,没看到他说的,我只看图片了。
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2020-7-8 18:25 , Processed in 0.153494 second(s), 26 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表