自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 1149|回复: 27

[脚本] 问一下,A与B如何互联

[复制链接]
发表于 2020-4-8 21:38:57 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
A与B在一个大内网里面,A和B都有自己不同的DHCP服务器,每7天更换一次IP地址,在无法使用DDNS的情况下,如何保证A与B的互联,而且每次更换IP地址后,对端能立即知道并更换成最新的IP地址?

我自己了半天,想用这样的方式,不知道行不行,大家给个意见,A建议L2TP server同时建立L2TP out,B也同理,互相拔号,然后再使用IP SEC或GRE或IPIP或EOIP的方式,使A跟B互联。不知道行不行,有人这样做过嘛?能给出出方法嘛?
routeros
发表于 2020-4-8 22:41:01 | 显示全部楼层
本帖最后由 47771885 于 2020-4-8 22:43 编辑

................那至少要用用脚本了
用ddns吧
routeros
发表于 2020-4-8 23:56:13 | 显示全部楼层
找个双方都可以访问且可以更改的东西,举例例如围脖之类
routeros
发表于 2020-4-9 09:23:15 | 显示全部楼层
找一个带外网固定地址的,A和B通过L2TP拨号
routeros
发表于 2020-4-9 10:03:13 | 显示全部楼层
ip --》 cloud  那边开启会有一个你的DDNS    例如 BXXXXXXXX.sn.mynetname.net   有了这个就可以 VPN
routeros
 楼主| 发表于 2020-4-10 21:18:09 | 显示全部楼层
没有互联网,就是个大内网。
routeros
发表于 2020-4-10 23:06:38 | 显示全部楼层
增加一个固定ip  。
routeros
 楼主| 发表于 2020-4-11 20:48:31 | 显示全部楼层
xuxi3201 发表于 2020-4-10 23:06
增加一个固定ip  。

没有固定IP地址。
routeros
 楼主| 发表于 2020-4-11 20:49:38 | 显示全部楼层
:global localip [/interface l2tp-server get  l2tp-in1 client-address ]
:global oldip [/interface l2tp-client get l2tp-out connect-to ]

:if ($localip != $oldip) do={

/interface l2tp-client

set connect-to=$localip numbers=0

:log warning "l2tp adderss genghuan ok";}

:log warning "l2tp address no bianhua";


写了这么一个脚本,目前还行,没啥事。大家看看怎么样。
routeros
发表于 2020-4-12 11:17:06 | 显示全部楼层
dhcp給的是private-ip還是public-ip ?
routeros
 楼主| 发表于 2020-4-12 22:05:35 | 显示全部楼层
cspm333 发表于 2020-4-12 11:17
dhcp給的是private-ip還是public-ip ?

私有IP,但是能互通。
routeros
发表于 2020-4-13 17:35:19 | 显示全部楼层
一樣透過ddns,但請使用可指定上傳ip的ddns與腳本,如:changeip 就不錯。
將私有ip(private-ip)更新到changeip的ddns裡。

這樣對端使用vpn連接時,解析changeip ddns時即能解出本地的私有地址(private-ip),
對本地進行連結囉。

至於mikrotick cloud似乎只能上傳公有地址(public-ip),您的環境就幫不上忙了。
routeros
发表于 2020-4-13 18:03:46 | 显示全部楼层
xuxi3201 发表于 2020-4-10 23:06
增加一个固定ip  。

我的方法是对的。
没有互联网。你的 ddns都用不起来。
routeros
 楼主| 发表于 2020-4-13 21:38:53 | 显示全部楼层
xuxi3201 发表于 2020-4-13 18:03
我的方法是对的。
没有互联网。你的 ddns都用不起来。

没有公网、没有固定IP地址、看来不好解决了。。。
routeros
发表于 2020-4-13 22:47:28 | 显示全部楼层
增加一个固定ip  。
我已经告诉你答案了,你怎么就不会呢。
哎呀。
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2020-6-6 02:51 , Processed in 0.169350 second(s), 24 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表