自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 637|回复: 12

[脚本] ros 查询ip地理位置

[复制链接]
发表于 2020-3-27 18:52:08 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 mrli 于 2020-3-27 18:53 编辑

查询ip地理位置

http://myip.chaip.vip:9080/

接口支持get post 方式


3PYWIQK${RJ9W)V))6J1.png
1585306026(1).jpg

支持查询指定ip  不提供ip参数 默认查询请求的ip地址


用途自由发挥




routeros
发表于 2020-3-28 16:57:11 | 显示全部楼层
請問有辦法轉換地理位置的語系嗎
routeros
 楼主| 发表于 2020-3-28 18:05:57 | 显示全部楼层
cspm333 发表于 2020-3-28 16:57
請問有辦法轉換地理位置的語系嗎

什么???

routeros
发表于 2020-3-28 19:19:11 | 显示全部楼层
本帖最后由 cspm333 于 2020-3-28 19:24 编辑

我是把"ip地理位置"改用mail發送通知,但信箱使用字型是Big5,會出現亂碼。
只有透過瀏覽器(萬國碼)收信才會正常顯示字串(中文名稱)。

所以想說若有法將地理位置改用英文名通知,自然不會有字型的問題了。


点评

这些不是问题  发表于 2020-3-29 12:45
routeros
发表于 2020-3-30 22:52:26 | 显示全部楼层
本帖最后由 cspm333 于 2020-3-30 23:15 编辑

目的是設計當有vpn用戶連線,可命系統mail到私人信箱進行通知。
原理是vpn帳戶可以綁一個profile設置,而連線成功後profile會運行on-up內的script。

1.png

2.png
:local date [/system clock get date]
:local time [/system clock get time]

:local yy [:pick $date 7 11]
:local mm [:find 0,jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec [:pick $date 0 3]]
:if ($mm<10) do={:set mm "0$mm"}
:local dd [:pick $date 4 6]
:set date "$yy/$mm/$dd"

:if (!($"caller-id" in 192.168.0.0/16)) do={
:local type [/interface get $interface type] ; :set type [:pick $type 0 [:find $type "-"]]
/tool fetch url="http://myip.chaip.vip:9080/ip\?ip=$"caller-id"" dst-path=from.txt
:local from [/file get from.txt contents] ; :set from [:pick $from [:find $from "["] ([:find $from "]"]+1)]
/tool e-mail send to="abc123@msa.hinet.net" subject="VPN-Client($user) login at $date $time" \
  body="\nDate : $date\r\nTime : $time\r\nFrom : $"caller-id" $from\r\nAddress : $"local-address"\r\nType : $type\r\nName : $user"
}


用戶連線後,信箱接收到的通知:
3.png
因字型讓地理位置產生亂碼,請問這要如何解決?

routeros
 楼主| 发表于 2020-3-31 10:50:49 | 显示全部楼层
cspm333 发表于 2020-3-30 22:52
目的是設計當有vpn用戶連線,可命系統mail到私人信箱進行通知。
原理是vpn帳戶可以綁一個profile設置,而 ...

你加我QQ把  541449269和我之前做的一样
http://bbs.routerclub.com/forum.php?mod=viewthread&tid=74801&extra=

routeros
 楼主| 发表于 2020-3-31 15:27:20 | 显示全部楼层
本帖最后由 mrli 于 2020-3-31 15:30 编辑
cspm333 发表于 2020-3-28 16:57
請問有辦法轉換地理位置的語系嗎

http://myip.chaip.vip:9080/ip?ip=2.2.2.2&character_code=tw

新增 character_code 参数 只接受 tw字符 转换为繁体
post 请使用json格式发送
HE4WQ@_U3X~_@{Q]3VHBIE0.png

JVUWTSR{90FF9PF($SOA8YW.png


ip和character_code 都是可选参数 默认都可以不传

点评

十分感謝,謝謝您^^  发表于 2020-3-31 21:49
routeros
 楼主| 发表于 2020-4-1 10:01:50 | 显示全部楼层
mrli 发表于 2020-3-31 15:27
http://myip.chaip.vip:9080/ip?ip=2.2.2.2&character_code=tw

新增 character_code 参数 只接受 tw字符  ...

查收邮件 还乱码不?
routeros
发表于 2020-4-2 15:57:50 | 显示全部楼层
mrli 发表于 2020-4-1 10:01
查收邮件 还乱码不?

問題只解決一半....
Snap6.jpg
擷取的字串若放在標題,字型是正確的;但換到內文,一樣是亂碼

routeros
 楼主| 发表于 2020-4-2 18:23:33 | 显示全部楼层
cspm333 发表于 2020-4-2 15:57
問題只解決一半....

擷取的字串若放在標題,字型是正確的;但換到內文,一樣是亂碼

541449269@qq.com
邮箱联系把

routeros
发表于 2020-4-2 21:20:43 | 显示全部楼层

您的指導是肯定的,同一封mail將語系換成GB18030就正常了。
2020-04-02 21-13-25 的螢幕擷圖.png
但系統選取 就以BIG5為先,沒法滿足。希望有兩全其美的辦法

routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2020-6-6 02:08 , Processed in 0.161149 second(s), 26 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表