自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 259|回复: 2

[基础] 求教ros下再下联的ros无法获取ipv6地址的问题

[复制链接]
发表于 2019-11-9 10:54:15 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
ROS pppoe拨号 获取了ipv6地址和前缀。配置好了ipv6 DHCP client和server。
主ros下的电脑已经可以正常自动获取ipv6地址。能正常上网。
但下联的ros无法获取ipv6地址。这个下联的ros只是作为ap用。所有端口都是在bridge中。配置了ipv6 dhcp client,状态一直是在搜索中。
请问下  是这么回事呢  谢谢
routeros
发表于 2019-11-9 13:37:50 | 显示全部楼层
抓不到地址,但手動指定還是可以安裝啟用。
因是浮動地址,所以還要搭支援ipv6的ddns才能借script更新。

去那找支援ipv6的ddns呢,mikrotik cloud便是了
routeros
发表于 2019-11-9 19:31:11 | 显示全部楼层
本帖最后由 cspm333 于 2019-11-9 20:36 编辑

Router2取得v6的地址很簡單。

假設Router1:
lan-local-address:fe80::764d:28ff:fe34:8541
cloud:31b60218c5d1.sn.mynetname.net

Router2新增:
/ipv6 firewall address-list
add list=r1v6 address="31b60218c5d1.sn.mynetname.net"

/ipv6 address
add address="::2/128" advertise=no interface=lan

/ipv6 route
add distance=1 dst-address=2000::/3 gateway="fe80::764d:28ff:fe34:8541%lan"

/system scheduler
新增v6排程腳本,每30s更新一次:
:local v6 [/ipv6 firewall address-list get [find list=r1v6 dynamic] address]
:set v6 "$[:pick $v6 0 [:find $v6 "::1/128"]]::2/128"
:local past [/ipv6 address get [find global] address]
:if ($past!=$v6) do={/ipv6 address set [find global] address=$v6}


routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2019-12-9 08:06 , Processed in 0.135056 second(s), 22 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表