自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 389|回复: 3

[脚本] 网银标记

[复制链接]
发表于 2019-8-20 18:37:08 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 e_zhangiso 于 2019-8-20 18:45 编辑

@cspm333大神,以下是大神在论坛提供的脚本,今天想把网银标记到一条固定线路,就在最新版的ROS6.44.5终端中运行了下,发现出现错误,以下是截图:
QQ图片20190820174855.png
附脚本:
:local 77RunSTR "yundaex,ytoexpress,sto.cn,800bestex,chinapost,ttkdex,zto,sf-express,ems,zjs,qfkd,deppon,hoau,sure56,uc56,ycgwl,jiayi56,lbex,fedex,dhl,tnt,ups,usps,183"
:foreach i in=[/ip dns cache find] do={
:foreach j in=[:toarray $77RunSTR] do={
:local doname [/ip dns cache get $i name]
:if ($doname~[:tostr $j]) do={
:local address [/ip dns cache get $i address]
:if ([:len [/ip firewall address-list find list=KuaiDi && address=$address]]=0) do={
/ip firewall address-list add list=KuaiDi comment=$doname address=$address timeout=1w}
    }
on-error={ }
      }
    }
  }

我想知道的是:1,ROS已经支持以域名方式添加到防火墙的地址列表,以上方法还需要使用吗?

                     2,对于像交通银行"http://www.bankcomm.com/BankCommSite/default.shtml"这样的网址,在地址列表中只能标记"www.bankcomm.com",能达到标记效果吗?

欢迎高手进来讨论,在多线路PCC负载均衡的情况下,是如何标记网银走固定线路,标记TCP 443端口走默认线路就不要说了,现在很多网站都是采取443访问,这样做只会流量不均.

routeros
发表于 2019-8-20 22:14:02 | 显示全部楼层
1.
最新版已經更新至6.45.3

2.
在terminal視窗sciprt不能直接貼上,要先在頭尾加上引號才能轉貼。如:
{
script內文
}

3.
script可以靠關鍵字找到網址相關的ip;address-list則要完整的網址才行。

4.
只有www.bankcomm.com才是連結地址,後面則是html文件路徑。

5.
先替網銀標記走固定線路,擺在PCC負載均衡之前就好,就這麼簡單。
是您想的太複雜,硬要將網銀插入PCC負載均衡之列。
routeros
 楼主| 发表于 2019-8-20 23:12:51 | 显示全部楼层
本帖最后由 e_zhangiso 于 2019-8-20 23:17 编辑
cspm333 发表于 2019-8-20 22:14
1.
最新版已經更新至6.45.3

在terminal視窗sciprt不能直接貼上,要先在頭尾加上引號才能轉貼。如:
{
script內文
}

1.按指导加了还是报错,和上面贴图一样;

2.没有把网银放在PCC中,只是把网银标记路由放在最上面,passthrough=no
routeros
 楼主| 发表于 2019-8-21 15:45:56 | 显示全部楼层
今天重新检查测试了下大神的脚本,发现粘贴的时候有个地方有遗漏,以下脚本经实测可以运行,但地址列表只添加一条记录

{
:local 77RunSTR "163.com,apple.com,yahoo.com"
:foreach i in=[/ip dns cache find]     do={
:foreach j in=[:toarray $77RunSTR]     do={
:local doname [/ip dns cache get $i name]
:if ($doname~[:tostr $j])  do={
                           do {
:local address [/ip dns cache get $i address]
:if ([:len [/ip firewall address-list find list=TEST && address=$address]]=0)    do={
/ip firewall address-list add list=TEST comment=$doname address=$address timeout=1w}
                                        }    on-error={}
                                  }
                          }
                 }
        }
}

routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2019-9-23 03:02 , Processed in 0.141439 second(s), 25 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表