自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 997|回复: 5

[脚本] aliyun ddns 更新接口 docker镜像启动

[复制链接]
发表于 2019-5-12 15:26:43 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 mrli 于 2019-5-12 15:36 编辑

此接口 基于docker镜像发布

安装完成docker后 (docker 安装自行百度  )    也可以联系我 免费部署

运行docker镜像 镜像默认端口:88


docker run -d -P --restart=always mrli20192019/flask_aliyun_ddns   
-P (大写的)随机映射一个端口到docker容器  执行 docker ps 查看映射的端口


docker run -d -p 80:88 --restart=always mrli20192019/flask_aliyun_ddns

把本机的80端口映射到容器的88端口  固定端口映射 前面可以加一个nginx做转发



查看日记
docker logs -t -f docker_ID
QQ图片20190512150455.png

随机映射的端口是  1026
QQ图片20190512150743.png

QQ图片20190512150805.png


QQ图片20190512150908.png
QQ图片20190512151007.png


QQ图片20190512151112.png
QQ图片20190512151333.png
QQ图片20190512151414.png


如果需要2级域名不存在 自动创建  联系QQ 541449269

AccessKeyID , AccessKeySecret 在阿里云帐号里面创建






routeros
 楼主| 发表于 2019-5-13 23:24:24 | 显示全部楼层
安装完docker后 直接执行上面的docker run这个命令即可 服务会自己启动 我已经把脚本和需要的东西全部打包进docker镜像里了 镜像是公开的 直接执行docker run会从docker镜像仓库里下载  无需任何配置
有问题请咨询 541449269
routeros
 楼主| 发表于 2019-5-14 21:41:53 | 显示全部楼层
更新脚本 发布
#2019-05-14
#author:mrli
#email:541449269@qq.com
#功能:阿里云ddns
#脚本在6.x 下执行
#Version:1.0
#ddns更新接口地址
:local url "http://ip"

:local AccessKeyID "xxx"

:local AccessKeySecret "xxx"

#需要更新的域名,域名必须在阿里云上
:local name "ddns-test.chaip.vip"

#更新域名IP的接口
:local Interface "pptp-out1"

#########以下脚本代码, 不懂ros脚本,请不要随意修改#######################
:global oldIP
:local localip
:foreach i in=[/ip address find interface=$Interface ] do={
:set localip [/ip address get $i address ]}
:set localip [:pick $localip 0 [find $localip /]]
:if ($localip != $oldIP) do={
set oldIP $localip
/tool fetch url=($url ."/aliyun_ddns/\?&domain=$name&AccessKeyID=$AccessKeyID&AccessKeySecret=$AccessKeySecret&ip=$localip" ) keep-result=no

:log info "aliyun ddns更新成功" } else={:log info "本地接口IP和域名IP一样,不用更新"}

routeros
发表于 2019-10-7 09:01:11 | 显示全部楼层
阿里云DDNS的更新脚本  具体怎么使用呢  谢谢
routeros
 楼主| 发表于 2019-10-7 21:02:32 | 显示全部楼层
z032 发表于 2019-10-7 09:01
阿里云DDNS的更新脚本  具体怎么使用呢  谢谢

你要自己按教程搭建服务器
routeros
发表于 2019-10-11 21:53:28 | 显示全部楼层
mrli 发表于 2019-10-7 21:02
你要自己按教程搭建服务器

谢谢  已经成功了  现在可以正常更新   好多年没有碰ROS了
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2019-10-19 18:04 , Processed in 0.180533 second(s), 28 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表