9939781 发表于 2015-5-3 13:56:24

【原创】VPLS+BGP基础应用

本帖最后由 9939781 于 2015-5-3 13:58 编辑

http://cache-1.oss-cn-beijing.aliyuncs.com/img/BGP-VPLS.png
假设某总公司R1的LAN1需要和分公司R2的LAN3进行L2桥接,并且LAN1和LAN3在同一个网段,要求LAN1和LAN3里的终端机器可以互相访问,支持MAC通讯,支持IPX通讯。(当然前提是LAN1和LAN3里的终端和终端之间IP不能冲突。)如果ISP禁止R1和R2之间进行BGP通讯需要先嵌套一个加密隧道,PPTP,L2TP,SSTP...等等都行。
按照如下配置关键内容即可实现需求,效果如图。

R1配置(部分关键配置示例):
/interface bridge
add auto-mac=yes disabled=no forward-delay=15s name=LAN1-LAN3 priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=LAN1-LAN3 interface=LAN1
/routing bgp instance
add as=65510 client-to-client-reflection=yes disabled=no ignore-as-path-len=no \
      name=65510 out-filter="" redistribute-connected=no redistribute-ospf=no \
      redistribute-other-bgp=no redistribute-rip=no redistribute-static=yes \
      router-id=1.1.1.1 routing-table=""
/routing bgp peer
add address-families=ip,l2vpn as-override=no default-originate=never disabled=\
      no hold-time=3m in-filter="" instance=65510 multihop=no name=65511 \
      nexthop-choice=default out-filter="" passive=no remote-address=1.1.1.2 \
      remote-as=65511 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=\
      default use-bfd=no
/interface vpls bgp-vpls add bridge=LAN1-LAN3 bridge-cost=20 export-route-targets=1:1 import-route-targets=1:1 name=1 route-distinguisher=1:1 site-id=1

R2配置(部分关键配置示例):
/interface bridge
add auto-mac=yes disabled=no forward-delay=15s name=LAN3-LAN1 priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=LAN3-LAN1 interface=LAN3
/routing bgp instance
add as=65511 client-to-client-reflection=yes disabled=no ignore-as-path-len=no \
    name=65511 out-filter="" redistribute-connected=no redistribute-ospf=no \
    redistribute-other-bgp=no redistribute-rip=no redistribute-static=yes \
    router-id=1.1.1.2 routing-table=""
/routing bgp peer
add address-families=ip,l2vpn as-override=no default-originate=never disabled=\
    no hold-time=3m in-filter="" instance=65511 multihop=no name=65510 \
    nexthop-choice=default out-filter="" passive=no remote-address=1.1.1.1 \
    remote-as=65510 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=\
    default use-bfd=no
/interface vpls bgp-vpls add bridge=LAN3-LAN1 bridge-cost=20 export-route-targets=1:1 import-route-targets=1:1 name=1 route-distinguisher=1:1 site-id=2

511789068 发表于 2015-5-4 10:13:58

好东西,谢谢分享!

wanken 发表于 2015-5-4 14:18:12

很久沒看到技術文章了,感謝版主先收起來了!

yjcoke 发表于 2015-5-10 23:05:26

如果不是同一个网段呢?

9939781 发表于 2015-5-10 23:57:02

yjcoke 发表于 2015-5-10 23:05
如果不是同一个网段呢?

PPTP完事,最简单了
页: [1]
查看完整版本: 【原创】VPLS+BGP基础应用