FreeBSD_shell 发表于 2012-6-16 18:54:50

手把手教你从配VLAN开始做PCC

本帖最后由 FreeBSD_shell 于 2012-6-16 18:58 编辑

PCC PPPOE效果图


哪进哪出效果图


PCC效果图


路由效果图


VLAN效果图


桥效果图


桥端口效果图




补充内容 (2012-6-25 10:15):
现在的人都是看见要铜板的就去看!觉得真的是论坛的悲剧!这贴竟然没有人看!

FreeBSD_shell 发表于 2012-6-16 19:00:15

下面说说配置华为的S系列交换机
华为的交换机带有中文的,这里就不多解释了
<Quidway>language-mode chinese        #设置为中文
<Quidway>system-view
interface Vlan-interface 1
ip address 192.168.254.254 255.255.255.0
local-user admin
service-type telnet level 3
password simple admin
user-interface vty 0 4
authentication-mode scheme
ip route-static 0.0.0.0 0.0.0.0 192.168.254.251
save

开始配置VLAN
vlan 2
port access vlan 2

配置trunk
port link-type trunk
port trunk permit vlan all

像TP-LINK那些直接用WEB页面进行配置的就不说了,这里直接上两个图大家一看也就知道了

FreeBSD_shell 发表于 2012-6-16 18:59:50

下面使用图文教程进行教大学从VLAN开始进行配置ROS多拔
首先我们设交换机吧:
下面以思科的2690与华为的S5000开始
先讲思科的:
用COM口线连进去交换机

下面开始配置IP地址,用于远程管理:
Press RETURN to get started!
Switch>enable
Switch#configure terminal
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.254.254 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.254.1
进入设置虚拟终端
Switch(config)#line vty 0 4
设置远程密码为admin
Switch(config-line)#password admin
Switch(config-line)#login
Switch(config-line)#exit
设置特权密码为admin
Switch(config)#enable secret admin
Switch#write

这样到时就可以远程连接进来配置交换机不用每次都用COM线了

IP配置完毕,下面开始配置VLAN:
创建一个Vlan2或者进入原来的Vlan2配置模式
Switch#configure terminal
Switch (config)# vlan 2
.......
Switch (config)# vlan 25
我们有24个100M的口与两个1000M的口,因为VLAN1是默认的所以我们从2到25

VLAN创建完毕,我们把端口加到VLAN里面
Switch(config-if)#interface fastEthernet 0/2
Switch (config-if)# switchport mode access
Switch (config-if)# switchport access vlan 2

Switch(config-if)#interface fastEthernet 0/3
Switch (config-if)# switchport mode access
Switch (config-if)# switchport access vlan 3

....................
....................

Switch(config-if)#interface fastEthernet 0/24
Switch (config-if)# switchport mode access
Switch (config-if)# switchport access vlan 24

Switch(config-if)#interface fastEthernet 0/1
Switch (config-if)# switchport mode access
Switch (config-if)# switchport access vlan 25

我们把1口设为VLAN25

下面我们配置trunk口,用于连接ROS.
Switch(config-if)#interface GigabitEthernet0/1
Switch(config-if)#switchport mode trunk

对于G2口如果要加入做trunk口就运行上面两条命令
如果要用做VLAN接入就运行上面VLAN命令

好了,思科的交换机配置完毕

FreeBSD_shell 发表于 2012-6-16 19:02:27

像TP-LINK那些直接用WEB页面进行配置的就不说了,这里直接上两个图大家一看也就知道了



FreeBSD_shell 发表于 2012-6-16 19:03:03

下面开始对ROS进行配置
我们使用WINBOX进去
配置IP地址那些就不说了,那些在网上一大堆
下面就说怎么使用脚本进行配置
我们来那建VLAN,网卡做PPPOE拔号我们使用WAN口
我们在左侧菜单栏里面找到New Terminal并打开
复制粘贴以下整行脚本内容运行即可 无错误即添加成功

FreeBSD_shell 发表于 2012-6-16 19:03:30

本帖最后由 FreeBSD_shell 于 2012-6-16 19:03 编辑

设置VLAN命令
:for i from=2 to=25 do= {/interface vlan add name=("VLAN".$i) vlan-id=$i interface=WAN}
设置桥用于拔号
:for i from=2 to=25 do= {/interface bridge add name=("bridge".$i) auto-mac=no admin-mac=("AA:AB:AC:AD:AE:".($i+10))}
把VLAN加入到桥
:for i from=2 to=25 do= {/interface bridge port add interface=("VLAN".$i) bridge=("bridge".$i)}
设置PPP拔号
:for i from=2 to=25 do= {/interface pppoe-client add name=("pppoe-out".$i) user=("user") password=("passwd") interface=("bridge".$i)}

FreeBSD_shell 发表于 2012-6-16 19:04:20

这些我都都做好了,那现在开始进行对线路进行标记与PCC设置
标记从哪条线路进就从哪条线路出
:for i from=2 to=25 do= {
        /ip firewall mangle
        add chain=input action=mark-connection new-connection-mark=("input".$i) in-interface=("pppoe-out".$i) comment=("Input".$i)
        add chain=output connection-mark=("input".$i) action=mark-routing new-routing-mark=("route".$i)
}
从哪进从哪出我们已经做好,现在设置PCC
这里由于有些LAN拔号也设了VLAN的,我们进行可移植的统一配置
/ip firewall address-list add address=1.2.3.4/24 disabled=no list=mark_route
:for i from=2 to=25 do= {
        /ip firewall mangle
        add chain=prerouting src-address-list=mark_route action=mark-connection comment=("Route".$i) \
        new-connection-mark=("conn".$i) per-connection-classifier=("both-addresses-and-ports:24/".($i-2))
       
        add chain=prerouting src-address-list=mark_route action=mark-routing new-routing-mark=("route".$i) connection-mark=("conn".$i)
}

FreeBSD_shell 发表于 2012-6-16 19:04:39

好了,PCC我们也已经设置好了
现在我们设置PCC的路由与标记的路由
:for i from=2 to=25 do= {/ip route add dst-address=0.0.0.0/0 gateway=("pppoe-out".$i) routing-mark=("route".$i)}

以上多线拔号已经完成了,是不是很简单....

FreeBSD_shell 发表于 2012-6-16 19:05:05

现在在给一组设置内网也是用VLAN的设置吧
如果在同一台机器上去做,VLAN_ID我们就用101开始吧
交换机的VLAN也自己根据实际修改吧
注意这里网卡是LAN
:for i from=101 to=124 do= {/interface vlan add name=("VLAN".$i) vlan-id=$i interface=LAN}
然后我们设置PPP服务
:for i from=101 to=124 do= {/interface pppoe-server server add authentication=pap default-profile=default disabled=no interface=("VLAN".$i) service-name=("service")}

具体的PPPOE设置也一大把

好了,ROS我们已经设置完毕了!

FreeBSD_shell 发表于 2012-6-16 19:15:22

bobwalker 发表于 2012-6-16 19:11 static/image/common/back.gif
谢谢整理。

您老怎么一直在论坛上转啊!只要有新贴你都.....

3148715 发表于 2012-6-16 20:00:18

看看怎么样

qwert1388 发表于 2012-6-16 20:40:30

ADSL吗         

FreeBSD_shell 发表于 2012-6-16 20:51:00

qwert1388 发表于 2012-6-16 20:40 static/image/common/back.gif
ADSL吗

是的,ADSL...

online2311 发表于 2012-6-16 23:10:55

不错!!支持下!哈哈

host2318 发表于 2012-6-17 07:33:20

早起特意来顶,谢谢分享!
页: [1] 2 3 4 5 6
查看完整版本: 手把手教你从配VLAN开始做PCC