45391710 发表于 2011-3-7 22:22:56

用一块外网网卡能支持多个PPPOE帐号吗

用一块外网网卡能支持多个PPPOE帐号吗

比如有九个PPPOE ADSL线路。。一个外网网卡可以支持九个吗

ROS不可能搞九块网卡吧

也没钱买交换机。。

想知道用一块外网网卡怎么样设置才能支持多个PPPOE帐号吗

kyer2012 发表于 2011-3-7 22:27:16

可以支持,只要加一个VLAN交换机,顺便提供一段代码给你,根据实际环境修改:

/interface vlan
add arp=enabled comment="" disabled=no interface=WAN mtu=1500 name=vlan1 \
    use-service-tag=no vlan-id=10
add arp=enabled comment="" disabled=no interface=WAN mtu=1500 name=vlan2 \
    use-service-tag=no vlan-id=20
add arp=enabled comment="" disabled=no interface=WAN mtu=1500 name=vlan3 \
    use-service-tag=no vlan-id=30
add arp=enabled comment="" disabled=no interface=WAN mtu=1500 name=vlan4 \
    use-service-tag=no vlan-id=40
add arp=enabled comment="" disabled=no interface=WAN mtu=1500 name=vlan5 \
    use-service-tag=no vlan-id=50
add arp=enabled comment="" disabled=no interface=WAN mtu=1500 name=vlan6 \
    use-service-tag=no vlan-id=60

/interface bridge
add admin-mac=00:31:98:A4:55:E8 ageing-time=5m arp=enabled auto-mac=no \
    comment="" disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s \
    mtu=1500 name=ADSL-1 priority=0x8000 protocol-mode=none \
    transmit-hold-count=6
add admin-mac=00:49:E2:CC:45:12 ageing-time=5m arp=enabled auto-mac=no \
    comment="" disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s \
    mtu=1500 name=ADSL-2 priority=0x8000 protocol-mode=none \
    transmit-hold-count=6
add admin-mac=00:30:D6:E0:0C:17 ageing-time=5m arp=enabled auto-mac=no \
    comment="" disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s \
    mtu=1500 name=ADSL-3 priority=0x8000 protocol-mode=none \
    transmit-hold-count=6
add admin-mac=00:C7:FE:DD:40:93 ageing-time=5m arp=enabled auto-mac=no \
    comment="" disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s \
    mtu=1500 name=ADSL-4 priority=0x8000 protocol-mode=none \
    transmit-hold-count=6
add admin-mac=00:BC:7D:AC:7E:3D ageing-time=5m arp=enabled auto-mac=no \
    comment="" disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s \
    mtu=1500 name=ADSL-5 priority=0x8000 protocol-mode=none \
    transmit-hold-count=6
add admin-mac=00:27:0A:C5:86:83 ageing-time=5m arp=enabled auto-mac=no \
    comment="" disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s \
    mtu=1500 name=ADSL-6 priority=0x8000 protocol-mode=none \
    transmit-hold-count=6

/interface bridge port
add bridge=ADSL-1 comment="" disabled=no edge=auto external-fdb=auto horizon=\
    none interface=vlan1 path-cost=10 point-to-point=auto priority=0x80
add bridge=ADSL-2 comment="" disabled=no edge=auto external-fdb=auto horizon=\
    none interface=vlan2 path-cost=10 point-to-point=auto priority=0x80
add bridge=ADSL-3 comment="" disabled=no edge=auto external-fdb=auto horizon=\
    none interface=vlan3 path-cost=10 point-to-point=auto priority=0x80
add bridge=ADSL-4 comment="" disabled=no edge=auto external-fdb=auto horizon=\
    none interface=vlan4 path-cost=10 point-to-point=auto priority=0x80
add bridge=ADSL-5 comment="" disabled=no edge=auto external-fdb=auto horizon=\
    none interface=vlan5 path-cost=10 point-to-point=auto priority=0x80
add bridge=ADSL-6 comment="" disabled=no edge=auto external-fdb=auto horizon=\
    none interface=vlan6 path-cost=10 point-to-point=auto priority=0x80

/interface pppoe-client add name=pppoe-out1 interface=ADSL-1 user=1 password=1 add-default-route=yes disabled=no
/interface pppoe-client add name=pppoe-out2 interface=ADSL-2 user=2 password=2 add-default-route=yes disabled=no
/interface pppoe-client add name=pppoe-out3 interface=ADSL-3 user=3 password=3 add-default-route=yes disabled=no
/interface pppoe-client add name=pppoe-out4 interface=ADSL-4 user=4 password=4 add-default-route=yes disabled=no
/interface pppoe-client add name=pppoe-out5 interface=ADSL-5 user=5 password=5 add-default-route=yes disabled=no
/interface pppoe-client add name=pppoe-out6 interface=ADSL-6 user=6 password=6 add-default-route=yes disabled=no


zooyo 发表于 2011-3-7 22:39:41

问题是没钱买交换机。

qinfei 发表于 2011-3-7 22:43:53

没钱买交换机就买九个网卡,加上内网一个,买十个,呵呵!不过也有别的网卡是一个PCI进去,几个以太网接口的,有点贵而已


网中漫步 发表于 2011-3-7 22:45:03

便宜的200-300就有了!:L

tangdong 发表于 2011-3-7 22:47:13

我发觉淘宝上卖的那些四口网卡就是因为ROS多AD接入的火热才水涨船高的,09年初买了几块150,HP的21143芯片的那个,现在基本都是翻倍的价格了!:lol

45391710 发表于 2011-3-7 23:06:42

用那个VRRP不可以解决吗

45391710 发表于 2011-3-7 23:08:00

回复 kyer2012 的帖子

先谢谢了。。没别的办法了吗。那有可以插九块网卡的机器呀

ccd5188 发表于 2011-3-7 23:42:56

顶,有用:):):)

47771885 发表于 2011-3-8 00:21:11

tangdong 发表于 2011-3-7 22:47 static/image/common/back.gif
我发觉淘宝上卖的那些四口网卡就是因为ROS多AD接入的火热才水涨船高的,09年初买了几块150,HP的21143芯片的 ...

哥60买了一张 英特 4口 551 的 用了半年 200 卖掉了

tangdong 发表于 2011-3-8 00:29:17

回复 47771885 的帖子

原来你就是幕后推手啊!:@

zooyo 发表于 2011-3-8 12:48:35

回复 47771885 的帖子

奸商啊,奸商。

kyer2012 发表于 2011-3-8 13:27:35

45391710 发表于 2011-3-7 23:06 static/image/common/back.gif
用那个VRRP不可以解决吗

那个只适合LAN终端小区网络!

45391710 发表于 2011-3-8 20:16:24

回复 kyer2012 的帖子

什么意思。。可以用那个解决 吗。我就 是小区网络呀

kyer2012 发表于 2011-3-8 20:41:28

45391710 发表于 2011-3-8 20:16 static/image/common/back.gif
回复 kyer2012 的帖子

什么意思。。可以用那个解决 吗。我就 是小区网络呀

意思就是你不需要modem就可以拨号的LAN终端网络!

如果是,可以按最新的那个帖子的技术去做VRRP!
页: [1] 2
查看完整版本: 用一块外网网卡能支持多个PPPOE帐号吗