277370403 发表于 2010-9-15 22:24:38

DSCP安装设置代码,卡了你抽我。

本帖最后由 277370403 于 2010-9-17 22:39 编辑

#Set interface here
:global outboundInterface "lan"
#Set bandwidth of the interface (remember, this is for OUTGOING)
:global interfaceBandwidth 0
#Set where in the chain the packets should be mangled
:global mangleChain postrouting

#Don't mess with these. They set the parameters for what is to follow
:global queueName ("qos_" . $outboundInterface)
:global qosClasses [:toarray "netcon,intercon,critical,flash_override,flash,immedate,priority,routine"]
:global qosIndex 64

#Set up mangle rules for all 64 DSCP marks
#This is different in that the highest priority packets are mangled first.
:for indexA from 63 to 0 do={
      /ip firewall mangle add \
      action=mark-packet \
      chain=$mangleChain \
      comment=("dscp_" . $indexA) \
      disabled=no \
      dscp=$indexA \
      new-packet-mark=("dscp_" . $indexA) \
      passthrough=no
}


#Add a base queue to the queue tree for the outbound interface
/queue tree add \
      max-limit=$interfaceBandwidth \
      name=$queueName \
      parent=$outboundInterface \
      priority=1

#Set up queues in queue tree for all 64 classes, subdivided by 8.
:for indexA from=0 to=7 do={
      :local subClass ([:pick $qosClasses $indexA] . "_" . $outboundInterface)
      /queue tree add \
                name=$subClass \
                parent=$queueName \
                priority=($indexA+1) \
                queue=ethernet-default
      :for indexB from=0 to=7 do={
                :set qosIndex ($qosIndex-1)
                /queue tree add \
                name=($subClass . "_" . $indexB) \
                parent=$subClass \
                priority=($indexB+1) \
                packet-mark=("dscp_" . $qosIndex) \
                queue=ethernet-default
      }
}

阿木DE 发表于 2010-9-15 22:41:38

铜板从哪里来?

qwert1388 发表于 2010-9-15 22:51:08

本帖最后由 qwert1388 于 2010-9-15 23:10 编辑

操官方大把还卡了抽你妈

ypw 发表于 2010-9-15 23:01:36

我买了

mching 发表于 2010-9-15 23:08:21

这,我买一个试试看看~~

9939781 发表于 2010-9-15 23:20:07

我操,40个,我还不如自己整

ypw 发表于 2010-9-15 23:29:06

上当了,大家不要买了,是官方的脚本
就是这个
#Set interface here
:global outboundInterface "lan"
#Set bandwidth of the interface (remember, this is for OUTGOING)
:global interfaceBandwidth 0
#Set where in the chain the packets should be mangled
:global mangleChain postrouting

#Don't mess with these. They set the parameters for what is to follow
:global queueName ("qos_" . $outboundInterface)
:global qosClasses [:toarray "netcon,intercon,critical,flash_override,flash,immedate,priority,routine"]
:global qosIndex 64

#Set up mangle rules for all 64 DSCP marks
#This is different in that the highest priority packets are mangled first.
:for indexA from 63 to 0 do={
      /ip firewall mangle add \
      action=mark-packet \
      chain=$mangleChain \
      comment=("dscp_" . $indexA) \
      disabled=no \
      dscp=$indexA \
      new-packet-mark=("dscp_" . $indexA) \
      passthrough=no
}


#Add a base queue to the queue tree for the outbound interface
/queue tree add \
      max-limit=$interfaceBandwidth \
      name=$queueName \
      parent=$outboundInterface \
      priority=1

#Set up queues in queue tree for all 64 classes, subdivided by 8.
:for indexA from=0 to=7 do={
      :local subClass ([:pick $qosClasses $indexA] . "_" . $outboundInterface)
      /queue tree add \
                name=$subClass \
                parent=$queueName \
                priority=($indexA+1) \
                queue=ethernet-default
      :for indexB from=0 to=7 do={
                :set qosIndex ($qosIndex-1)
                /queue tree add \
                name=($subClass . "_" . $indexB) \
                parent=$subClass \
                priority=($indexB+1) \
                packet-mark=("dscp_" . $qosIndex) \
                queue=ethernet-default
      }
}

WGHBOY 发表于 2010-9-15 23:54:38

哈哈,目前还没见过有真正的dscp出现,都是忽悠贴

heguo2008 发表于 2010-9-16 00:17:06

哈哈,目前还没见过有真正的dscp出现,都是忽悠贴是吗

yblgzz 发表于 2010-9-16 02:43:59

忽悠死你们,呵呵

filandcome 发表于 2010-9-16 03:29:48

铜板从哪里来?

imxch 发表于 2010-9-16 08:07:58

忽悠的啊,赚个铜板

geshenggang4 发表于 2010-9-16 23:05:26

哈哈全!!!

47771885 发表于 2010-9-17 00:04:07

有钱人真多

火蚂蚁 发表于 2010-9-17 00:22:27

fdsadfsadfdsaf
页: [1] 2 3
查看完整版本: DSCP安装设置代码,卡了你抽我。