自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 637|回复: 6

[基础] 动态dhcp下怎么做路由

[复制链接]
发表于 2021-9-18 01:13:22 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
收了一只map玩,就是只有一个eth一个wlan的东西。
原来的设想是eth做dhcp client,不做默认路由,然后梯子一个出去,所有wlan来的全部走梯子出去
因为没了默认路由,我以为可以手动做一个指定路由梯子的ip给eth,结果发现原来是走不通的,一定要设个网关ip上去,问题是dhcp,网关ip是不确定的啊,这怎么弄?
routeros
发表于 2021-9-18 08:15:19 | 显示全部楼层
本帖最后由 cspm333 于 2021-9-18 08:17 编辑

假設路由表策略標記名稱為wlan,在dhcp-client裡加script讓腳本自己修改gateway即可。
2021-09-18 08-10-53 的螢幕擷圖.png
  1. /ip route set [find routing-mark="wlan"] gateway=$"gateway-address"
复制代码
routeros
发表于 2021-9-18 12:15:50 | 显示全部楼层
/ip dhcp-client
add default-route-distance=2  disabled=no interface=ether1


这样不香吗

点评

湘哥威武  发表于 2021-9-18 12:27
routeros
 楼主| 发表于 2021-9-18 12:21:10 | 显示全部楼层
cspm333 发表于 2021-9-18 08:15
假設路由表策略標記名稱為wlan,在dhcp-client裡加script讓腳本自己修改gateway即可。

...

我应该表述错了,rb的eth是dhcp client,然后rb拨梯子,然后其他用户通过rb的wlan再通过rb的梯子出去。现在的问题是,我关闭了rbdhcp client的默认路由,梯子直接就拨不出去了(因为没路由),我之前以为可以单独写一条梯子服务器ip的路由给eth,结果发现是不行的
routeros
发表于 2021-9-18 14:25:27 | 显示全部楼层
  1. {
  2. :local rmark "test"
  3. :local count [/ip route print count-only where comment=$rmark]
  4. :local wadd $"gateway-address"
  5. :if ($bound=1) do={
  6. :if ($count = 0) do={
  7. /ip route add gateway=$wadd comment=$rmark routing-mark=$rmark
  8. } else={
  9. :if ($count = 1) do={
  10. :local test [/ip route find where comment=$rmark]
  11. :if ([/ip route get $test gateway] != $wadd) do={
  12. /ip route set $test gateway=$wadd
  13. }
  14. } else={
  15. :error ("ERR\5B".$rmark."\5D");
  16. }
  17. }
  18. }
  19. }

复制代码


放入dhcp   script 内 IP发生变化后自动修改标记路由网关
routeros
 楼主| 发表于 2021-9-18 21:08:19 | 显示全部楼层
按三楼搞定了,直接把默认的default-route-distance=1改低,然后就可以随便整了(只要其他路由比它高就行了)
ros办法就是多,就是想没想到而已
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2021-10-25 18:40 , Processed in 0.044431 second(s), 17 queries , Gzip On, MemCached On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表