自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 2822|回复: 18

[vpn] 问个问题ros如何修改L2TP默认的1701端口呢?

[复制链接]
发表于 2020-5-17 12:05:03 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
如题。很多地方L2TP的UDP 1701端口是被封了的,有什么办法修改这个端口呢?谢谢
routeros
发表于 2020-5-17 14:26:44 | 显示全部楼层
本帖最后由 cspm333 于 2020-5-17 15:08 编辑

l2tp設計是死的...不能改就是不能改。
但繞點路卻可以,但要router才辦的到,手機沒辦法。

原本是1701->1701 ,但1701->17010->1701也是可以啦!
客戶端:將連接對端port:1701(l2tp)的連線,透過nat映射變更成連接對端port:17010
伺服端:將連接本地端port:17010的連線,透過nat映射還原回l2tp原本port:1701
routeros
 楼主| 发表于 2020-5-17 14:56:13 | 显示全部楼层
本帖最后由 v808comd 于 2020-5-17 15:05 编辑

感谢楼上大神  总是能帮我解答问题  总是非常热心乐于助人 再次感谢
如果是伺服端  是这样来做的吗?  不用写to-addr 直接写to端口号?就是映射给自己吗?
[admin@MikroTik] /ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic
0    chain=dstnat action=dst-nat to-ports=1701 protocol=udp
      dst-address=202.x.x.x dst-port=1722 log=no log-prefix=""
routeros
发表于 2020-5-17 15:03:22 | 显示全部楼层
本帖最后由 cspm333 于 2020-5-17 15:07 编辑
v808comd 發表於 2020-5-17 14:56
感謝樓上大神  總是能幫我解答問題  總是非常熱心樂於助人 再次感謝
如果是伺服端  是這樣來做的嗎?  不用 ...

客戶端:
/ip firewall nat add action=dst-nat chain=dstnat dst-address=202.x.x.x protocol=udp dst-port=1701 to-port=1722

伺服端:
/ip firewall nat add action=dst-nat chain=dstnat protocol=udp dst-port=1722 to-port=1701


routeros
 楼主| 发表于 2020-5-17 15:09:06 | 显示全部楼层
我是伺服端  我的1701是被封的 要给改成1722 让客户端来连接。
您给的写法 是不是action写反了?
routeros
发表于 2020-5-17 15:16:08 | 显示全部楼层
本帖最后由 cspm333 于 2020-5-17 15:28 编辑
v808comd 發表於 2020-5-17 15:09
我是伺服端  我的1701是被封的 要給改成1722 讓客戶端來連接。
您給的寫法 是不是action寫反了? ...

沒錯啊,l2tp伺服端的port是1701。
所以伺服端,是將客戶端目地port(dst-port=1722),轉回原本的1701(to-port=1701)

routeros
 楼主| 发表于 2020-5-17 15:18:22 | 显示全部楼层
明白了  再次感谢
routeros
 楼主| 发表于 2020-5-17 16:36:27 | 显示全部楼层
本帖最后由 v808comd 于 2020-5-17 16:53 编辑

两端都是ros  不知道为什么  没有成功
routeros
 楼主| 发表于 2020-5-17 16:55:21 | 显示全部楼层
cspm333 发表于 2020-5-17 15:03
客戶端:
/ip firewall nat add action=dst-nat chain=dstnat dst-address=202.x.x.x protocol=udp dst-por ...

客户端是不是action 和chain  都应该是srcnat
routeros
发表于 2020-5-17 17:33:50 | 显示全部楼层
本帖最后由 cspm333 于 2020-5-17 17:45 编辑
v808comd 發表於 2020-5-17 16:55
客戶端是不是action 和chain  都應該是srcnat

a.png

不管是客戶端或伺服端,來源(src)與目的(dst)的相對位置並不會改變。



routeros
 楼主| 发表于 2020-5-17 17:49:25 | 显示全部楼层
在客户端上 pppoe接口torch观察  用dstnat  不能改变目的端口号
用srcnat 就是把自己的端口号改了  
反正都不成
routeros
发表于 2020-5-17 17:55:29 | 显示全部楼层
v808comd 发表于 2020-5-17 17:49
在客户端上 pppoe接口torch观察  用dstnat  不能改变目的端口号
用srcnat 就是把自己的端口号改了  
反正都 ...

你做稍稍改變,伺服端映射設置再加上to-addresses=192.168.x.x(您的router內網地址)試試。
routeros
 楼主| 发表于 2020-5-17 19:35:43 | 显示全部楼层
本帖最后由 v808comd 于 2020-5-17 19:50 编辑
cspm333 发表于 2020-5-17 17:55
你做稍稍改變,伺服端映射設置再加上to-addresses=192.168.x.x(您的router內網地址)試試。
...

伺服器和客户端都在公网上 伺服器是固定ip    客户端是pppoe动态ip
没有在内网上的     所以nat更改端口不成功
最根本的问题是  双方都可以改变源端口  却不能改变目的端口。可能在客户端ros前再加一个ros来nat改变下源端口 或许能成。

点评

若您的網路來源是dhcp-client是可以透過映射變動的;但我也試了pppoe,如您所敘真的沒法透過映設改變。  发表于 2020-6-2 12:02
routeros
发表于 2020-6-2 11:49:46 | 显示全部楼层
建议用OVPN或SSTP,PPTP/L2TP有RFC标准,要改两边都得改
routeros
发表于 2020-6-2 12:17:07 来自手机 | 显示全部楼层
我用sstp,同城市,电信。复制文件速度1MB多。换了一个办法达到5MB。请问sstp速度怎么上去?
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2020-10-30 11:46 , Processed in 0.164873 second(s), 27 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表