自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 164|回复: 2

[脚本] ros 架设自己的域名更新服务器 源码 PHP

[复制链接]
发表于 2019-11-7 20:33:27 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 47771885 于 2019-11-7 20:55 编辑

论坛很久没有人发有点可玩性的东西了
本届MUM 本想 分享下 ROS 筛选IP 的高效应用脚本 报名晚了下回再说吧

这里就先发个 ros 架设自己的域名更新服务器 源码 PHP自动 创建 更新 自己的域名

真正自己掌控自己的域名 拒绝一切信息泄露
有了这个源码 不单是ros 可以更新自己的域名 。。其他设备
比思科路由等都可以 随意更新自己的域名



本程序需要使用阿里云接口

需要满足的条件

1 域名是在阿里云或者万网注册的并且已经实名 (不是的话可以转入)需要使用   AccessKey ID        Access Key Secre
2 需要有一个可以自行PHP 的环境

需要有一定的动手和理解能力

本程序为精简版本 单文件 有动手能力的可以根据核心逻辑动手改进任何需要的功能
IPV6 更新等等等。。。

配套的更新脚本说明
因为是精简程序 参数都是文件内置了

{
##www.ros.sh 2019
:local rr "test"
:local result
/tool fetch url="https://1.1.1.1/api/rosddns.php\?rr=$rr" dst-path=rosip mode=https
:delay 1
:set result [/file get rosip contents]
:delay 1
/file remove rosip;
:if ($result!="ok") do={
:log warning $result
}
}



:local rr "test" 设置为需要更新的二级域名字段
url="https://1.1.1.1/api/rosddns.php\?rr=$rr" 设置为更新服务器IP和程序地址 如果是http mode=https 也需要改成http
可选参数 ?rr=$rr&ip=1.1.1.1
如不指定IP参数 则自动识别当前主机公网Ip
精力有限 欢迎大家跟帖贴上成功步骤

帮助更多新人

源码和应用有很大改进空间适合喜欢动手的


源码和 更新脚本都在附件中了
www.ros.sh 得闲公开海量 原创 ros 脚本









dns.zip

2.2 KB, 下载次数: 5

售价: 2 铜板  [记录]

routeros
发表于 2019-11-8 13:13:53 | 显示全部楼层
还没有试验,先看看,今天上软坛,就看见湘哥发帖,真是荣幸之至啊
routeros
发表于 6 天前 | 显示全部楼层
本帖最后由 mrli 于 2019-11-11 11:11 编辑

http://bbs.routerclub.com/thread-104797-1-1.html
aliyun ddns 更新接口 docker镜像启动

支持开源更多实用脚本和工具....


routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2019-11-17 11:30 , Processed in 0.143262 second(s), 26 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表