自由的生活_软路由论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 209|回复: 4

[脚本] 如何将数字转变为对应的字母

[复制链接]
发表于 2019-9-30 16:22:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
请教大神,数字1,2,3---12,分别对应英文one.two.three-----twelve,变量aa可能是1,2,3-----12中的任何一个数字,请问如何用脚本将变量aa由数字转变为对应的英文字母?
routeros
发表于 2019-9-30 17:45:14 | 显示全部楼层
Snap4.png
routeros
 楼主| 发表于 2019-9-30 21:11:45 | 显示全部楼层

感谢cspm33大神的回复,可能是我没有阐述全面,我的外线是PPPOE拨号,pppoe-client是tel-1,tei-2,tel-3-------tel-12,我通过脚本从/ip route中判断出默认网关为tel-3时,将网关接口tel-3中的3提取出来用变量aa表示,下面一步是我想实现的,如何将变量aa转换为英文"three";如果默认网关是tel-5,则将数字5转换为英文"five"
routeros
发表于 2019-9-30 21:47:35 | 显示全部楼层
本帖最后由 cspm333 于 2019-9-30 22:03 编辑

:local num [:toarray "0,one,two,three,four,five,six,seven,eight,nine,ten,eleven,twelve"]
:foreach i in=[/ip route find gateway~"^tel" ([:len $"routing-mark"]>0)] do={
:local mark "tel-$[:pick $num [:pick [/ip route get $i gateway] 4 6]]"
:if ([/ip route get $i routing-mark]!=$mark) do={/ip route set $i routing-mark=$mark}
}

routeros
 楼主| 发表于 2019-9-30 21:59:47 | 显示全部楼层
cspm333 发表于 2019-9-30 21:47
:local num [:toarray "0,one,two,three,four,five,six,seven,eight,nine,ten,eleven,twelve"]
:foreach i  ...

测试通过,万分感谢!
routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|软路由论坛 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

GMT+8, 2019-10-19 18:01 , Processed in 0.159973 second(s), 25 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4 Licensed

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表